Closed Bug 1544727 Opened 6 months ago Closed 6 months ago

Moz-phab always fails with IOError when setting up logs.

Categories

(Conduit :: moz-phab, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emilio, Assigned: glob)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Since I updated moz-phab today, I can't do anything:

IOError: [Errno 2] No such file or directory: '/home/emilio/.mozbuild/moz-phab/moz-phab.log'

My moz-phab file is not in ~/.mozbuild, and that directory obviously doesn't exist.

Can we not hardcode the log location please?

Oh, if I uncomment the logging initialization, the directory gets created.

oops; sorry about that.

~/.mozbuild/moz-phab/ is created by moz-phab as a place to store its copy of arc.
i'll initialise that sooner.

Assignee: nobody → glob
Priority: -- → P1
Duplicate of this bug: 1544673

I see that this landed, but it's not yet in the shipping moz-phab version.

Can we issue an update ASAP to get this fixed? Otherwise this may waste a bunch of people's time today...

I just ran moz-phab self-update to get version 1.21 [at moz-phab's suggestion] and stumbled over this bug (which I worked around by creating the directory) -- and repeated moz-phab self-update runs don't seem to get me the fix.

(Also, $HOME/.mozbuild isn't necessarily the right directory -- there's an env variable that moz-phab should be preferring if it's set. I filed bug 1544902 on that.)

i've released 1.22.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.