ValueError: Google Chrome not currently integrated!

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: whimboo, Assigned: igoldan)

Tracking

(Regression, {regression})

Version 3
mozilla68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

Since bug 1539437 landed Florin and I experienced the following problem when running Raptor with Chrome:

10:04:18 FATAL - Uncaught exception: Traceback (most recent call last):
10:04:18 FATAL - File "/home/florinstrugariu/mozilla/mozilla-central/testing/mozharness/mozharness/base/script.py", line 2089, in run
10:04:18 FATAL - self.run_action(action)
10:04:18 FATAL - File "/home/florinstrugariu/mozilla/mozilla-central/testing/mozharness/mozharness/base/script.py", line 2028, in run_action
10:04:18 FATAL - self._possibly_run_method(method_name, error_if_missing=True)
10:04:18 FATAL - File "/home/florinstrugariu/mozilla/mozilla-central/testing/mozharness/mozharness/base/script.py", line 1983, in _possibly_run_method
10:04:18 FATAL - return getattr(self, method_name)()
10:04:18 FATAL - File "/home/florinstrugariu/mozilla/mozilla-central/testing/mozharness/mozharness/mozilla/testing/raptor.py", line 278, in install_chromium_distribution
10:04:18 FATAL - raise ValueError("Google Chrome not currently integrated!")
10:04:18 FATAL - ValueError: Google Chrome not currently integrated!

Why don't we allow Chrome? Ionut, can you get this fixed please?

Flags: needinfo?(igoldan)

(In reply to Henrik Skupin (:whimboo) [⌚️UTC+1] from comment #0)

Since bug 1539437 landed Florin and I experienced the following problem when running Raptor with Chrome:

10:04:18 FATAL - Uncaught exception: Traceback (most recent call last):
10:04:18 FATAL - File "/home/florinstrugariu/mozilla/mozilla-central/testing/mozharness/mozharness/base/script.py", line 2089, in run
10:04:18 FATAL - self.run_action(action)
10:04:18 FATAL - File "/home/florinstrugariu/mozilla/mozilla-central/testing/mozharness/mozharness/base/script.py", line 2028, in run_action
10:04:18 FATAL - self._possibly_run_method(method_name, error_if_missing=True)
10:04:18 FATAL - File "/home/florinstrugariu/mozilla/mozilla-central/testing/mozharness/mozharness/base/script.py", line 1983, in _possibly_run_method
10:04:18 FATAL - return getattr(self, method_name)()
10:04:18 FATAL - File "/home/florinstrugariu/mozilla/mozilla-central/testing/mozharness/mozharness/mozilla/testing/raptor.py", line 278, in install_chromium_distribution
10:04:18 FATAL - raise ValueError("Google Chrome not currently integrated!")
10:04:18 FATAL - ValueError: Google Chrome not currently integrated!

Why don't we allow Chrome? Ionut, can you get this fixed please?

I wasn't really sure if the Chromium binary path from install_chromium_distribution() was compatible with the Google Chrome ones. Removing this check should be plain easy, though I will need to know more about your local setups: e.g. where have you installed Google Chrome in your file system & what CLI command are you running?

Flags: needinfo?(igoldan)

Note: a fix for this bug will only enable running Raptor locally, which can point to Google Chrome. But pushing a PR to mozilla-central which uses old chrome mentionings will fail. That browser isn't yet available there. We may have a long way until that happens.

(In reply to Ionuț Goldan [:igoldan], Performance Sheriffing from comment #2)

Note: a fix for this bug will only enable running Raptor locally, which can point to Google Chrome. But pushing a PR to mozilla-central which uses old chrome mentionings will fail. That browser isn't yet available there. We may have a long way until that happens.

Yep that's fine, we definitely need to be able to run against Chrome proper locally, if you could fix this ASAP please :igoldan that'd be great, thanks!

Flags: needinfo?(igoldan)
Assignee: nobody → igoldan
Flags: needinfo?(igoldan)

Comment 5

2 months ago
Pushed by igoldan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a9c6ef836b4a
Enable chrome CLI app argument r=rwood

Comment 6

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.