Closed Bug 1544779 Opened 4 years ago Closed 8 months ago

Win10 64 bit Make version too old. Only versions strictly greater than 4.0 are supported.. Stop.

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox100 fixed)

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: dev.raj.polinovsky, Assigned: glandium)

Details

(Keywords: in-triage)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36

Steps to reproduce:

  1. Download and install all soft for create build from source.
  2. Run hg clone https://hg.mozilla.org/releases/mozilla-release release (last release)
  3. Create .mozconfig in release folder.
    Config:
    mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-ff
    ac_add_options --target=x86_64-pc-mingw32
    ac_add_options --host=x86_64-pc-mingw32
  4. Run start-shell.bat (mozilla-build version 3.2)
  5. In start console cd to release folder
  6. Run ./mach build

Actual results:

After same time I have error:
0:00.87 Clobber not needed.
0:00.87 Adding make options from e:\firefox\release.mozconfig
CONFIG_GUESS=x86_64-pc-mingw32
MOZ_OBJDIR=e:/firefox/release/obj-ff
OBJDIR=e:/firefox/release/obj-ff
FOUND_MOZCONFIG=e:/firefox/release/.mozconfig
export FOUND_MOZCONFIG
0:00.96 e:\mozilla-build\bin\mozmake.EXE -f client.mk -s
0:01.27 e:/firefox/release/config/baseconfig.mk:32: *** Make version too old. Only versions strictly greater than 4.0 are supported.. Stop.
0:01.27 mozmake.EXE: *** [client.mk:125: build] Error 2
0:01.34 0 compiler warnings present.

Expected results:

Create build

Component: Untriaged → General
Product: Firefox → Firefox Build System

I changed the steps to build:
./mach bootstrap
./mach build

But error not delete:
$ ./mach build
0:06.66 Clobber not needed.
0:06.70 Adding make options from e:\firefox\release.mozconfig
CONFIG_GUESS=x86_64-pc-mingw32
MOZ_OBJDIR=e:/firefox/release/obj-ff
OBJDIR=e:/firefox/release/obj-ff
FOUND_MOZCONFIG=e:/firefox/release/.mozconfig
export FOUND_MOZCONFIG
0:06.87 e:\mozilla-build\bin\mozmake.EXE -f client.mk -s
0:07.33 e:/firefox/release/config/baseconfig.mk:32: *** Make version too old. Only versions strictly greater than 4.0 are supported.. Stop.
0:07.33 mozmake.EXE: *** [client.mk:125: build] Error 2
0:07.40 0 compiler warnings present.

We got another report of this in chat today.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 68 Branch → unspecified

The issue in chat was caused by two reasons:

  1. The user had their own MinGW installation in their $PATH
  2. We prioritize several make variants (including mingw32-make) over our bootstrapped make
  3. (EDIT): MozillaBuild 4.0 also stopped resetting the %PATH% like previous MozillaBuild installations, so external tools are once again visible to the build system.

One solution here is to look for make variants, ignoring any of them that don't meet our make version requirements. If none match that filter, then bootstrap.

Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/6e0fdf97afdc
Prioritize mozmake over mingw32-make. r=firefox-build-system-reviewers,andi
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
You need to log in before you can comment on or make changes to this bug.