Closed Bug 1544824 Opened 1 year ago Closed 1 year ago

Navigate to list view when current add-on is removed

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

Details

Attachments

(2 files)

If you remove an add-on on its detail view then the page is navigated to the list view. However, if you remove the add-on from the browser action, another about:addons page, about:debugging or some other way then the page does not change.

The DetailView should be listening for the add-on to be removed with an AddonListener rather than listening to the "remove" event from AddonCard.

In addition, if the add-on isn't found on load then we should redirect to the list view.

Blocks: 1545427
No longer blocks: 1525173
Duplicate of this bug: 1545409
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4cc7642d8e0f
Redirect to list view when an extension is removed r=rpl
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Attached image Bug1544824.gif

I was able to reproduce this issue on Firefox 68.0a1 (20190517214313) under Win 7 64-bit.

This issue is verified as fixed on Firefox 69.0a1 (20190523215203) and Firefox 68.0b3 (20190523115432) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached video.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.