Closed Bug 1544894 Opened 7 months ago Closed 7 months ago

When updating with BITS, the notification mode does not properly switch between "active" and "idle"

Categories

(Toolkit :: Application Update, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: bytesized, Assigned: bytesized)

References

Details

Attachments

(1 file)

BITS update notifications are supposed to change frequency when a listener is actively receiving notifications and then change back to a lower frequency when the listener unregisters. Currently, this is not happening properly.

I had thought that this was due to onUnload not being called properly, but after fixing that (Bug 1544562), the problem is still happening.

Pushed by ksteuber@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7c149c2cd4a9
Fix bug where BITS notifications never return from active to idle mode r=rstrong
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.