Closed Bug 1544950 Opened 1 year ago Closed 10 months ago

[about:addons] warning messages for extensions disabled by Firefox (because of being blocked or legacy)

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox68 --- verified
firefox69 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

Details

Attachments

(3 files, 2 obsolete files)

Add-ons currently show a message when they've been blocklisted. We should include whatever message there is now in the new about:addons.

Priority: -- → P1
Summary: Blocklisted add-on message → [about:addons] Blocklisted add-on message
Summary: [about:addons] Blocklisted add-on message → [about:addons] Add-on warning messages

There are also global warning messages that should likely be converted to message bars and displayed at the top of the page. https://searchfox.org/mozilla-central/rev/94c6b5f06d2464f6780a52f32e917d25ddc30d6b/toolkit/mozapps/extensions/content/extensions.xul#343-368

The browser_langpack_signing.js test should be updated or replaced.

Summary: [about:addons] Add-on warning messages → [about:addons] Add-on warning messages for extensions disabled by Firefox (because of being blocked or legacy)
Summary: [about:addons] Add-on warning messages for extensions disabled by Firefox (because of being blocked or legacy) → [about:addons] warning messages for extensions disabled by Firefox (because of being blocked or legacy)
Assignee: nobody → mstriemer
Attachment #9071148 - Attachment is obsolete: true
Attachment #9071147 - Attachment is obsolete: true
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b2640d94e07
Part 1: Add-on warning messages for HTML about:addons r=rpl
https://hg.mozilla.org/integration/autoland/rev/361431c79de4
Part 2: Global add-on warnings for HTML about:addons r=rpl

Comment on attachment 9071149 [details]
Bug 1544950 - Part 2: Global add-on warnings for HTML about:addons

Beta/Release Uplift Approval Request

  • User impact if declined: When add-ons are disabled for various reasons, such as being unsigned, blockedlisted or incompatible the user will not be able to tell why the add-on is disabled.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Visual changes implemented based off of the existing code in the XUL about:addons. Has test coverage.
  • String changes made/needed: No
Attachment #9071149 - Flags: approval-mozilla-beta?
Attachment #9071146 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9071146 [details]
Bug 1544950 - Part 1: Add-on warning messages for HTML about:addons

fixes for html about:addons, approved for 68.0b10

Attachment #9071146 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9071149 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: in-testsuite+
Attached image Red+Yellow warnings.png

Verified the fix on the latest Release (68.0 / 20190705220548), Beta (69.0b3 / 20190708182549) and Nightly (70.0a1 / 20190709153742) in addition to the latest Unbranded Beta (69.0b3 / 20190708182549) and the older Nightly version (69.0a1 / 20190708095055), older Beta version (68.0 / 20190705220548) and the older Unbranded Beta version (68.0b14 / 20190627143605) under Windows 10 Pro 64-bit and Ubuntu 16.04.6 LTS.

To generate the specified warnings I have set the following preferences in about:config on a fresh profile created in Nightly:

  • extensions.getAddons.discovery.api_url to -dev server
  • xpinstall.signatures.dev-root to true
  • xpinstall.signatures.required to false

Note: This profile has been migrated to all tested builds.

Upon setting the mentioned preferences, several recommended add-ons from the -dev server have been installed and the preferences have been reset to their default values.

After a short period of time, the red warning was displayed under each of the add-on cards and the extensions have been disabled.

Flipping the ‘xpinstall.signatures.required’ pref back to ‘false’ will generate the yellow warning under the extension cards.

The mentioned warnings are also displayed in the detail view of the affected add-ons.

This was the behavior observed for the latest Nightly (70.0a1 / 20190709153742), latest Unbranded Beta (69.0b3 / 20190708182549) and the older versions of Nightly (69.0a1 / 20190708095055) and Unbranded Beta (68.0b14 / 20190627143605). For further details, please see the attached screenshot.
For the rest of the tested builds, only the red warning has been displayed as the ‘xpinstall.signatures.dev-root’ pref, which is needed for the -dev AMO server works only in Nightly and Unbranded Beta builds.

Before closing the issue as Fixed, please let me know if this is the correct and intended behavior of this feature.

Flags: needinfo?(mstriemer)
Status: RESOLVED → VERIFIED
Flags: needinfo?(mstriemer)
You need to log in before you can comment on or make changes to this bug.