Closed Bug 1544957 Opened 1 year ago Closed 1 year ago

Jumping to large files renders calls an expensive CodeMirror function twice

Categories

(DevTools :: Debugger, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1553291

People

(Reporter: Harald, Unassigned)

References

(Blocks 1 open bug)

Details

Rendering a large minified file in the Debugger caused 2 consecutive hangs, 2.3s and 1.7s. Both seem to be the same CodeMirror function (column). This is a known performance bottleneck, also seen in https://github.com/firefox-devtools/debugger/issues/7134 .

The issue here is that these are two separate hangs; which might hint that the Debugger is calling or resetting CodeMirror unnecessarily.

https://perfht.ml/2UmgOBl

Priority: -- → P1
Priority: P1 → P2
Whiteboard: [debugger-mvp]
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1553291

This 6 year old(!) hack is apparently helpful but we can't trust it as-is and it appears invasive:

https://github.com/codemirror/CodeMirror/commit/b88e8c3f8077a2481b0f26c3b74a7913cacac00f

Whiteboard: [debugger-mvp]
You need to log in before you can comment on or make changes to this bug.