Closed Bug 154496 Opened 18 years ago Closed 6 years ago

Domain Guessing: list of TLD's other then .com

Categories

(SeaMonkey :: Location Bar, enhancement)

x86
Linux
enhancement
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME
Future

People

(Reporter: sledgehammer2010, Assigned: adamlock)

References

Details

(Keywords: helpwanted)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020610
Debian/1.0.0-1
BuildID:    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020610
Debian/1.0.0-1

I would like to see the browser search more Top Level Domains (TLD's) than just
.com, when a partial address is entered.

Reproducible: Always
Steps to Reproduce:
1.  Enter a partial URL (e.g., 'mozilla') in the location bar.
2.  Hit 'Enter'


Actual Results:  The partial URL is expanded to 'http://www.mozilla.com'.  When
this is not found, no attempt is made to find 'http://www.mozilla.org' or
'http://www.mozilla.edu', etc.

Expected Results:  It would be nice to have some sort of order that is
automatically followed.  Opera, for example, let's you configure a list of TLD's
to search, and in what order (in Opera, it is referred to as name completion).
URI Fixup
Assignee: Matti → adamlock
Whiteboard: DUPEME
URL: N/A
Component: Browser-General → URL Bar
Future.

Potentially it's possible but we'd have to store the original url and where we
are in the sequence of alternates. It would be tricky to get right.

Note that you can change the default fixup prefix and postfix from www. & .com
to something else (e.g. www. & .org) with prefs. See nsDefaultURIFixup.cpp for
details.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Target Milestone: --- → Future
QA Contact: imajes-qa → benc
Summary: Completion for TLD's other then .com → Domain Guessing: list of TLD's other then .com
*** Bug 314233 has been marked as a duplicate of this bug. ***
The list should be completely configurable, as in Opera.  For some people, assuming .com would be a bad thing.  (The case of a grade school student searching on "whitehouse" is an example.)
Depends on: 331510
No longer depends on: 331510
Product: Core → SeaMonkey
See browser.fixup.alternate.suffix pref
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.