Closed Bug 1544998 Opened 1 year ago Closed 11 months ago

Search bar autocomplete popup has poor contrast in dark mode

Categories

(Firefox :: Theme, defect, P3)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: nightly-community, Whiteboard: fixed by bug 1561894)

Attachments

(1 file, 1 obsolete file)

Attached image search bar contrast.png (obsolete) —

STR:

  1. enable browser.in-content.dark-mode
  2. Enable separate search bar
  3. Type something into the search bar

What happens:

The colors and contrast in the search bar does not look good.

Expected result:

Text should have better contrast, colors should look better.

Sorry if I'm missing something, but which search bar looks wrong and how is it supposed to look like ?

Flags: needinfo?(yoasif)
Priority: -- → P5
Attached image search contrast.png

Ooops, forgot that taking a screenshot of a window won't take a screenshot of the search popup.

Attachment #9058839 - Attachment is obsolete: true
Flags: needinfo?(yoasif)

Thanks for the screenshot!

This doesn't seem related the in-content dark mode, since this UI is styled even without.

No longer blocks: dark-incontent-pages
Summary: Search bar in dark mode has bad contrast/styling → Search bar autocomplete popup in dark mode has poor contrast

So the problem is that searchbar.inc.css uses --panel-disabled-color for text that isn't disabled.

Priority: P5 → P3
See Also: → 1520522
Summary: Search bar autocomplete popup in dark mode has poor contrast → Search bar autocomplete popup has poor contrast in dark mode
Status: NEW → RESOLVED
Closed: 11 months ago
Depends on: 1561894
Resolution: --- → FIXED
Whiteboard: fixed by bug 1561894
You need to log in before you can comment on or make changes to this bug.