Closed Bug 1545034 Opened 6 months ago Closed 5 months ago

Significant increase of loading times on CodiMD caused with bug 1504947

Categories

(Core :: JavaScript Engine, defect)

68 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + disabled

People

(Reporter: denschub, Unassigned)

References

(Regression, )

Details

(Keywords: regression, Whiteboard: [qf:p1:pageload])

Attachments

(1 file)

The latest patch (8eaa269b362f) landed in bug 1504947 8 days ago apparently causes some significant increases of loading time on CodiMD.

If you try to load this pad in a Nightly after landing that patch, you'll notice a significant delay (multiple seconds) between the header showing up and the pad actually loading. Before landing that patch, the loading starts almost instantaneously.

Here are profiles from loading said pad to compare:

Jeff, as discussed on IRC, I'd appreciate if you could take a look at this. :)

Flags: needinfo?(jwalden)
Type: task → defect

[Tracking Requested - why for this release]:
Perf regression.

Unsurprisingly inverting that first-bad profile shows up TokenStreamSpecific::columnAt as the culprit. The profile identifies the script that was being parsed at the time, but loading the URL manually hits a 404 -- maybe it was a temporary one-off thing. Still looking to see if I can pull it up to identify the characteristics of the source text that mean the current column-caching approach doesn't work enough...

maybe it was a temporary one-off thing

No. Loading https://demo.codimd.org/z4lH4LmqQIqTqr9Vg4b0-Q still results in the same behavior. The hashes in the JS URLs did change (it's now https://demo.codimd.org/build/index-pack.cfd5a8ec26563ff8d00c.js), but that's probably just because they deployed a new version.

Sorry, I meant that URL might have been a one-off URL only accessible on a per-visitor basis. Thanks for the new packed URL, it's exactly what I was looking for.

Whiteboard: [qf]
Whiteboard: [qf] → [qf:p1:pageload]
Depends on: 1549758

Fixed by the reversion in bug 1549758.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(jwalden)
Resolution: --- → FIXED

(And incidentally, bug 1551916's patchwork handle parsing the problematic script here just fine, without observable delay, when we get the column number semantics changed back to code points again.)

You need to log in before you can comment on or make changes to this bug.