PAC: does not load easily on startup

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: aaronis31337, Unassigned)

Tracking

({helpwanted})

Trunk
x86
Windows XP
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
At many organizations, they require a configuraiton script to inform the 
browser about proxy configs.  On Mozilla, this script does not load properly.  
Consistenly, my home page will not come up.  Instead, i must reload after it 
fails.  

This is not an issue on explorer.

Thanks for your time.

Comment 1

16 years ago
Can you give your config? Does it work after hitting reload? Does clearing the
cache solve the problem?
QA Contact: benc → pacqa
Summary: Configuraton script does not load easily on startup → PAC: does not load easily on startup

Comment 2

16 years ago
*** Bug 154852 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
Doug, this is one of the PAC bug reports I consider serious. I've added to the
eng triage list (helpwanted), and will do some testing if I can before I leave
this Fri.
Keywords: helpwanted

Comment 4

16 years ago
-> me (sent mail to reporter requesting additional info)
Assignee: new-network-bugs → darin
Severity: major → minor

Comment 5

16 years ago
Let me try to add additional comments since I experience this problem as well...

When loading mozilla browser you recieve error:

    ALERT
        www.google.com could not be found.  Please check the name and try again.

To fix the problem, you need to go into the Preferences->Advanced->Proxies and
reload the Automatic Proxy Configuration.  Once this is done it works fine for
the length of the session.

This error occours approx 65% of the time I go into Mozilla and 100% of the time
following a reboot. 

Comment 6

16 years ago
darren: thanks for the additional info.  can you please do one more thing which
is to enable some mozilla logging?  completely shutdown mozilla (be sure to exit
quick launch), and then open a DOS prompt and run these commands:

c:\> set NSPR_LOG_MODULES=nsHttp:5
c:\> set NSPR_LOG_FILE=c:\http.log
c:\> cd \path\to\mozilla
c:\> .\mozilla.exe

repro the problem, exit mozilla, and then upload c:\http.log to this bug report.

thanks in advance!!

Comment 7

16 years ago
Created attachment 104658 [details]
http.log from darren fuller

Comment 8

16 years ago
confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

15 years ago
I took a quick look at this log, but could not see anything going wrong. I'll
need to get more familiar w/ HTTP logs when PAC is on to understand this.
QA Contact: pacqa → benc

Updated

13 years ago
Assignee: darin → nobody
QA Contact: benc → networking
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.