Closed Bug 1545080 Opened 7 months ago Closed 7 months ago

"Send to" -> Mail recipient" not working for attachment with non-english filename

Categories

(Thunderbird :: OS Integration, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1531724

People

(Reporter: cra3yk, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36

Steps to reproduce:

  1. Create files for test using new -> text document, and name it
    a ć.txt (polish c with ' - alt+c in polish programmers)
    a ó.txt (polish o with ' - alt+o in polish programmers)

  2. using windows explorer select
    a ć.txt
    or / and
    a ó.txt

then: right click -> "Send to" -> Mail recipient"

Actual results:

nothing

Expected results:

https://i.imgur.com/Mcu1TPR.png

New compose window should appear with selected attachments (like picture above)

It works, when attachment file names doesn't have "foreign" chars (only plain english chars) like:
a a.txt
a b.txt

This problem in on Windows 7 (64 bit, I didn't tested on 32 bit). It works on Windows 10 1709 or later)

It stopped working when TB was updated to 60.x.x version (even new install of 60.x.x doesn't help at all), but it works (with foreign chars in attachment file names) in TB 52.x.x or earlier.

Your description matches bug 1530820, fixed in 60.5.3 bug 1531724

You don't state your version of Thunderbird, found at help > about.

Flags: needinfo?(cra3yk)

Version 60.6.1

Flags: needinfo?(cra3yk)

system locale is set to Polish pl-PL

the bug 1530820 is/was different bug, because sending from external programs were not working at all (no works), but sending files (with names different than english) by using method from my first post - not working at all.

The bug 1530820 is/was different bug, because sending from external programs were not working at all, because of that bug.

Now sending from external programs (via MAPI) works, but sending files (with names different than english) by using method from my first post (select file with non-english name, right click-> -> "Send to" -> Mail recipient" - not working at all.)

This should work in principle, see bug 1530820 comment #30 and bug 1531724. There can still be quibbles with registry entries, see the release notes:

https://www.thunderbird.net/en-US/thunderbird/60.5.3/releasenotes/
If resetting the registry entries to 0 doesn't help, remove them instead, see bug 1530820 comment #145

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1531724

Ok. Had to delete "SupportUTF8" entry from HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla Thunderbird and HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Clients\Mail\Mozilla Thunderbird

Problem solved. Thank You!

PS: setting to 0 doesn't change anything

You need to log in before you can comment on or make changes to this bug.