Open Bug 1545082 Opened 6 months ago Updated 5 months ago

Steam website breaks with Firefox with ESET NOD32 Antivirus installed. Works fine with Edge.

Categories

(Firefox :: Untriaged, defect)

66 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

UNCONFIRMED

People

(Reporter: tanin99, Unassigned, NeedInfo)

Details

Attachments

(5 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Firefox 66.0.3 Fresh New Setup - No Addons
Windows 10 64bit New Setup - build 1809 latest build
Location: Europe
DSL - stable fast connection - 40Mb down / 3Mb Up
Ethernet LAN Wired connection

  1. Open https://store.steampowered.com/genre/Free%20to%20Play/
  2. Scroll down and click on a button named: "Browse All New Releases"
  3. Select page number 3 and then 5 and then 7 until images are broken / thumbnails not loaded.
  4. Press Reload-current-page button does NOT fix the issue, the page remains half loads and broken.
  5. Close firefox and relaunch it
  6. Enter a direct link of your previous failed to load page. (in my case this page failed along with many others - https://store.steampowered.com/search/?sort_by=Released_DESC&tags=-1&genre=Free%20to%20Play&page=7)
  7. Upon opening new firefox with direct link that previously failed, the page loads perfectly. Page loads perfect with all images and no broken image links

Attached screenshots.

Actual results:

Steam pages fail to load , only on Firefox.
Workaround to close Firefox and enter the failed page with direct link , sometimes fixes loading the page.

Expected results:

Firefox should successfully load Steam pages, like Edge does with no issues.

Severity: normal → minor
Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → INVALID
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Attached root cause for corrupting Firefox functionality and breaking down all images and videos on Stream - the root cause is web filtering that is always default on ESET NOD32 Antivirus - also included in screenshots the exact version of the Antivirus and the setting location that breaks Firefox.

Severity: minor → major
Type: defect → task
Priority: -- → P1
Priority: P1 → --

Reported directly to ESET, their response is to add Steam to safe websites, but their default settings break Firefox functionality and they disregard nor consider it as a bug and point to their article of safe websites - https://support.eset.com/kb2960/
I don't know what can be done on Firefox end to ensure ESET fixes their product from breaking Firefox worldwide to all customers who are not advanced and know how to add websites to specific locations in the advanced settings of ESET Antivirus, nor do most not even know that is the reason their Firefox breaks and their websites fail to load properly.

Flags: needinfo?(andrei.vaida)
Type: task → defect
Has STR: --- → yes
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: Steam website breaks only with Firefox, works fine with Edge → Steam website breaks with Firefox with ESET NOD32 Antivirus installed. Works fine with Edge.

Hi Tom, what additional info are looking for ?

Attached image ESET-License.png

I have tested this issue using Fx 66.0.3 on Windows 10 x64 platform, build 1809, with free ESET NOD32 Antivirus version 12.1.34.0 and ESET Smart Security Premium with license I have attached a screenshot with the second antivirus (ESET-License.png). The issue is not reproducible for me with the previous assumptions, also not reproducible on Windows 10 32 bit platform. Tested on Firefox latest nightly 68.0a1 (2019.04.22) and on Firefox 67.0b12 I have not found any irregularities.

Flags: needinfo?(andrei.vaida)

Timea, I've reproduced this issue over and over on every 1809 fresh setup with NOD32 12.1.34.0 breaking Firefox 66.0.3 again and again, not until I've added Steam to the safe websites on NOD32 Advanced setup , web protection > safe URLs. What additional data are you missing to reproduce the issue on your end too ?

Flags: needinfo?(timea.zsoldos)

We have tested again and have payed attention that ESET NOD32 Antivirus do not add anything to the "List of addresses excluded from checking" list by default, the issue is not reproducible. Then add the : https://store.steampowered.com/genre/Free%20to%20Play/ link to this address list
and without disabled application protocol content filtering, the issue is reproducible only one time, some pages fail to load, but after disabled application protocol content filtering every page was loaded. Then even if I uninstall/reinstall the antivirus (by default the protocol is enabled, and the address list is empty) not reproduced anymore.
We tried it in another network, another PC but nothing, every page was loaded in every circumstances.
Please tell me if I can help with anything else!

Flags: needinfo?(timea.zsoldos)

The problem is not with that specific link (https://store.steampowered.com/genre/Free%20to%20Play/)

The pages start to break once you apply the TWO steps afterwards 2 and 3 (as listed in the original reproduction steps above):

  1. Scroll down and click on a button named: "Browse All New Releases"
  2. Select page number 3 and then 5 and then 7 until images are broken / thumbnails not loaded.

Also,
3a. Once you enter one of the games from the list in step 3, with a broken image/thumbnail, inside the game page, all the content in that game page, will fail to load, videos, images, all media will fail to load.

The ESET Antivirus DOES breaks those pages on Firefox, and once ESET's web protection is disabled, Steam pages recover and load properly on Firefox, with a single page refresh.

Updated details in my recent reply above ^^

Flags: needinfo?(timea.zsoldos)

Hi John, I tried the setup environment with a clean Windows 10 x64 (1809), fresh install of Eset NOD32 12.1.34.0 and a fresh install of Firefox 66.0.3 and I encountered the issue once.

I tried reproducing by navigating through the pages with lists of games 2 by 2 (and other combinations) and it wouldn't reproduce, then I just got to the Store Home and let the big tiles on top of the page which were presenting games to change by themselves. After going through 3 to 4 tiles, it would not load the next thumbnails and pages.

After a refresh, the pages loaded properly and no matter what I did (reinstalled the Firefox, reinstalled Eset, new profiles, etc) to try and reproduce it again, I was not able to (I can say that it was a flaw from my internet connection, but I may be wrong).

Eventually, could you look over and try to reproduce the issue with another internet connection (like a mobile hotspot maybe), or on another system? Or there could be another app on the background which could be interfering with Firefox and ESET?

Flags: needinfo?(timea.zsoldos)

Catalin, I wanted to point out, once Firefox manage to cache/load the thumbnails once, the cache and cookies remain, so the pages will reload successfully if the pages have been cached. The problem is with all the pages that have not been cached, new pages as described in step 3 of the reproduction steps.

Flags: needinfo?(catalin.sasca)

Yeah, but wouldn't the cache/load be cleared if Firefox/Profile/Temp files are deleted? I only encountered the issue once, and the internet connection dropped as well for me that particular time, so I could easily blame that (I put the ESET to strict mode as well and nothing happened). Other than that, everything worked as expected.

I will try and reproduce it again on another system, just to make sure it is working properly.

Flags: needinfo?(catalin.sasca)
Attached image NetLimiter.png

In another attempt to reproduce the scenario; we've tried limiting the network, but this might be another issue since as seen in the attached Screenshot only part of the thumbnails where broken.
Will post the profiler link for this in case it does turn out to be the same.

@John, is the issue still reproducing with the current Release build?
If so, another thing that would help out is using the profiler addonand sharing the results.
Also could you recheck and do a ping test while trying to navigate on the sites?

Flags: needinfo?(tanin99)

@Karl, mind taking a look at the above and confirming if it would be the case or is it something different?
Thank you!

Flags: needinfo?(kdubost)
<div class="col search_capsule">
  <img src="https://steamcdn-a.akamaihd.net/steam/apps/1025260/capsule_sm_120.jpg?t=1553852612">
</div>
HTTP/2.0 200 OK
last-modified: Fri, 15 Mar 2019 16:56:06 GMT
etag: "5c8bd926-f07"
server: nginx/1.10.3 (Ubuntu)
content-type: image/jpeg
content-length: 3847
access-control-allow-origin: *
accept-ranges: bytes
cache-control: public, max-age=361320
expires: Mon, 13 May 2019 05:30:30 GMT
date: Thu, 09 May 2019 01:08:30 GMT
X-Firefox-Spdy: h2

All the images are coming from akamaihd.net and displays correctly without the antivirus (as said previously).
I'm on macOS 10.14
I have not installed ESET

Not the first time such issues are reported though.
https://support.mozilla.org/en-US/questions/1105023
SSL scanning maybe https://support.eset.com/kb3126/

It seems to be intermittent, and related to https scanner.
https://forum.eset.com/topic/6528-https-scanner-blocking-access-to-sites-pictures-for-no-reason-in-all-browsers-on-1-computer/

Maybe Firefox is a bit more sensitive but this seems to happen in more browsers than just Firefox. Just hard to reproduce from everything you can read online.

Flags: needinfo?(kdubost)
Severity: major → normal
Attached image ESET_Workaround.png
Flags: needinfo?(tanin99)

Christian, after applying the attached ESET workaround,
The issue is not occurring in Firefox, but for the thousands or millions of people that don't know this workaround,
The issue will occur.

Details above + new attachment

Flags: needinfo?(cristian.fogel)

Thank you for confirming the workaround!

Unfortunately with or without the workaround, we are still unable to reproduce the issue on several of our units.
While we are still looking into it, we're trying to find out as many details as possible so details about your setup are apreciated.

Could you also try checking with a new profile?

  • See this link for information on how to do that.

Also, it would help if you could post the error messages listed in the browser console (Ctrl+Shift+J) after the issue is reproduced.

Flags: needinfo?(cristian.fogel) → needinfo?(tanin99)

Windows 1903 is out , I'll verify a fresh FF 67 install on it and add more info to this ticket in few days.

Flags: needinfo?(tanin99)

Hey John, any updates with this?

Flags: needinfo?(tanin99)
You need to log in before you can comment on or make changes to this bug.