Closed Bug 1545096 Opened 6 months ago Closed 5 months ago

Page does not pan when having data inserted in a text field

Categories

(Core :: Panning and Zooming, defect, P3)

68 Branch
ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1516722
Tracking Status
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: diana.rus, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Environment:
Device: Sony Xperia Z5; Xiaomi Mi4i (Android 5.0.2); OnePlus A3000 (Android 6.0.1)
Build: Nightly 68.0a1 (2019-04-16)

Steps to reproduce:

  1. Go to page https://bugzilla.mozilla.org/home
  2. Tap on "Advanced Search" option
  3. Enable "Detailer Bug Information" section
  4. Zoom in and pan to right until the "Whiteboard" text field is half displayed
  5. Tap in the "Whiteboard" text field
  6. Insert data into the field until it reaches the end of the screen's visible area

Expected Result: The page should pan to the right as you type into the text field and reach the right margin of the zoomed area.

Actual Result: The page does not pan when text reaches the right margin of the zoomed area

NOTE: The issue cannot be reproduced on Beta(67.0b11) and neither on Release(66.0.2)

Hi,

The following results are present after regression window with Sony Xperia Z5 (Android 7.0)

  • last good build: 2019-04-09; changeset: 9eb55c9bf557d9b683d4808620e26da6e242c4b0
  • first bad build: 2019-04-09; changeset: 6efaae3bcd67bc0881a114c5c7dbd319e6b4abc2

Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9eb55c9bf557d9b683d4808620e26da6e242c4b0&tochange=6efaae3bcd67bc0881a114c5c7dbd319e6b4abc2

I think this issue was introduced with the patches from 1516056 @Botond Ballo, can you please take a look?
With respect,
Diana Rus

Flags: needinfo?(botond)
Regressed by: 1516056
Component: Keyboards and IME → Panning and Zooming
Product: Firefox for Android → Core
Version: Firefox 68 → 68 Branch

I believe this is a case of bug 1516056 making bug 1516722 more noticeable.

This should be fixed by bug 1516722, but leaving open so we can confirm this.

Depends on: 1516722
Flags: needinfo?(botond)

Hello Diana - Can you confirm this is fixed based on Comment 2? Thanks.

Flags: needinfo?(diana.rus)

Hello,

I confirm, the issue has been fixed.

Environment
Device: Sony Xperia Z5 (Android 7.0.0)
Build: Firefox Nightly 68.0a1 (2019-05-08)

I will mark the issue as resolved.

Regards,
Diana Rus

Flags: needinfo?(diana.rus)
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
No longer depends on: 1516722
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1516722
You need to log in before you can comment on or make changes to this bug.