ftp has problems with trailing spaces

VERIFIED FIXED in M12

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Paul MacQuiddy, Assigned: Andreas Otte)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
ftp should remove trailing spaces from URL's. As an example, try  entering
ftp://ftp.mozilla.org and add a trailing space. On linux, you will get an
authorization dialog. On windows, nothing will load. If you remove the space,
you will see the directory layout correctly.

Using an 10/3 M11 build on Linux/Windows
ftp is not working at all on Mac right now so can't test

Updated

19 years ago
Assignee: valeski → andreas.otte

Comment 1

19 years ago
reassigning to andreas as his latest stdURL patch will cover this.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 14380 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 3

19 years ago
Although the bug this one is marked as a duplicate of is fixed by gagan, this
one seems not to be fixed. CCing gagan, starting investigation.
(Assignee)

Updated

19 years ago
Target Milestone: M12

Comment 4

19 years ago
This is different then what I fixed. Andreas your patch is the correct thing to
do. I can check it in on your behalf if you want.
(Assignee)

Updated

19 years ago
Status: VERIFIED → REOPENED

Updated

19 years ago
Resolution: DUPLICATE → ---

Comment 5

19 years ago
Clearing DUPLICATE resolution due to reopen.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
fix checked in.

Comment 7

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Comment 8

19 years ago
verified:  NT 2000012520
           Linux 2000012520
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.