Closed Bug 1545125 Opened 1 year ago Closed 1 year ago

Loading tab context menu FTL prevents intl.uidirection from working without a restart

Categories

(Core :: Internationalization, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox68 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

Details

Attachments

(1 file)

STR:

  1. Start Firefox
  2. Go to about:config, and set intl.uidirection to 1
  3. Notice how the UI direction changes immediately.
  4. Reset the pref, so that the UI direction goes back to LTR.
  5. Open the tab context menu by right-clicking on any tab
  6. In about:config, set intl.uidirection to 1 again

ER:

The UI direction should change again immediately.

AR:

The UI direction in the browser UI remains fixed. This is because Fluent is placing a localedir attribute on the root node here:

https://searchfox.org/mozilla-central/rev/d33d470140ce3f9426af523eaa8ecfa83476c806/intl/l10n/DOMLocalization.jsm#598-602

after the tab context menu FTL is attached here:

https://searchfox.org/mozilla-central/rev/d33d470140ce3f9426af523eaa8ecfa83476c806/browser/base/content/tabbrowser.js#4748-4759

Blocks: 1534389
Assignee: nobody → mconley

This way, if the user updates the pref, we can properly set the localedir
on Fluent-translated documents.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5becec174411
Notify DOMLocalization if the intl.uidirection pref has been changed. r=zbraniecki
Component: Tabbed Browser → Internationalization
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Flags: qe-verify+

Hi,

I tested this issue on Windows 10 with an old Nightly build 68.0a1 (20190416095014) and I was able to reproduce it.
I also tested it using the latest Nightly build 69.0a1 (2019-06-26) and latest Beta version 68.0b13 (20190624133534) and I'm not able to reproduce the issue. Based on this I will mark the bug as Verified.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.