[android x86-64] dom/ipc/tests/test_force_oop_iframe.html | application crashed [@ mozilla::dom::TabParent::RemoveWindowListeners()]

REOPENED
Unassigned

Status

()

defect
P3
normal
REOPENED
2 months ago
2 months ago

People

(Reporter: Nika, Unassigned)

Tracking

({intermittent-failure, leave-open})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell disabled])

Attachments

(2 attachments)

This is an error in M[tier-2](2) on Android 7.0 x86-64 opt which seems to have gone perma-orange with my stack landing on autoland: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=running%2Csuccess%2Ctestfailed%2Cbusted%2Cexception%2Crunnable&searchStr=android%2C7.0%2Cx86-64%2Copt%2Cmochitests%2Ctest-android-em-7.0-x86_64%2Fopt-mochitest-e10s-2%2Cm(2)&selectedJob=240970026&revision=3592e8434aa07e699e29a1abcb96c72d5f9eb9f0

This appears to be caused by the Document associated with the frameloader of a tab being gone during shutdown, despite the corresponding content process and its nsFrameLoaders not being dead yet.

The crashing line appears to be: https://searchfox.org/mozilla-central/rev/d33d470140ce3f9426af523eaa8ecfa83476c806/dom/ipc/TabParent.cpp#358. It may be possible to fix by also null-checking OwnerDoc() in that if statement.

Assignee: nobody → nika

This line appears to be perma-failing right now in Android 7.0 x86-64 opt : M[tier-2](2). This seems to be being caused by the PContent's
channel being closed during shutdown also causing TabParents to be shut
down too late, after the document which they're embedded in has started
dying(?)

This patch just does the "obvious" thing of adding a null check (due to
it looking like a null dereference).

Comment hidden (Intermittent Failures Robot)

Comment 3

2 months ago
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24545a98e9e1
Check that OwnerDoc is non-null within RemoveWindowListeners, r=qdot
Whiteboard: [stockwell needswork:owner]
Comment hidden (Intermittent Failures Robot)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

Comment 6

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

This not yet fixed, see #c5.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla68 → ---
Comment hidden (Intermittent Failures Robot)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork]
Comment hidden (Intermittent Failures Robot)

Updated

2 months ago
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]

Comment 11

2 months ago
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2049f9466646
Disabled test_force_oop_iframe.html on Android opt r=jmaher
Comment hidden (Intermittent Failures Robot)

We are not currently planning on working with oop iframes on android immediately, and this particular form of oop iframes will not be present in that situation. It's probably OK that this test is disabled for now, though perhaps we will need to come back to it in the future.

Assignee: nika → nobody
Flags: needinfo?(nika)
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.