Closed Bug 1545253 Opened 1 year ago Closed 1 year ago

[socket process] Allow OnStatus/OnProgress before OnStartRequest in pBg

Categories

(Core :: Networking: HTTP, defect, P2)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: junior, Assigned: junior)

References

(Blocks 1 open bug, Regression)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

If OnStatus/OnProgress is sent before OnStartRequest, we can call OnStatus/OnProgress the listener in child process before OnStartRequest arrives.

This patches need some polished since resource loading is obviously stuck.

HttpBackgroundChannelChild::RecvOnStartRequestSent() is sent from Parent to Content process now.
However, (a) Bug 1510961 introduce ODA from Socket to Parent. We still want to prevent ODA before OnStartRequest.

(b) OnStatus/OnProgress are allowed to be sent before OnStartRequest if the order also stands in parent process.
We need to use some flags to let (a)(b) happen.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.