Permafailing create interactive task ac(create-inter) HTTPError: 400 Client Error: Bad Request for url: http://taskcluster/queue/v1/task/MsOmu2NoR427QR8759QNcg

RESOLVED FIXED in Firefox 68

Status

defect
P5
normal
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: intermittent-bug-filer, Assigned: aki)

Tracking

(Regression, {intermittent-failure, regression})

unspecified
mozilla68

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 months ago
treeherder

#[markdown(off)]
Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=241016540&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/f5FYTeIdT--7MvxzvlwHlw/runs/0/artifacts/public/logs/live_backing.log

*Example task details:* https://tools.taskcluster.net/groups/YgDcfh93SqWPwR-905WKWg/tasks/H18CvRe1StG7O60ulzodAQ/details

[task 2019-04-17T18:37:01.388Z] Creating task with taskId UIlEmMv-SiW8aAIKkKuquA for test-linux64/debug-marionette-e10s
[task 2019-04-17T18:37:01.671Z]
[task 2019-04-17T18:37:01.671Z] Schema Validation Failed!
[task 2019-04-17T18:37:01.671Z] Rejecting Schema: https://schemas.taskcluster.net/queue/v1/create-task-request.json#
[task 2019-04-17T18:37:01.671Z] Errors:
[task 2019-04-17T18:37:01.671Z] * data.dependencies should NOT have duplicate items (items ## 3 and 0 are identical)
[task 2019-04-17T18:37:01.671Z]
[task 2019-04-17T18:37:01.671Z] ---
[task 2019-04-17T18:37:01.671Z]
[task 2019-04-17T18:37:01.671Z] * method: createTask
[task 2019-04-17T18:37:01.671Z] * errorCode: InputValidationError
[task 2019-04-17T18:37:01.671Z] * statusCode: 400
[task 2019-04-17T18:37:01.671Z] * time: 2019-04-17T18:37:01.620Z
[task 2019-04-17T18:37:01.672Z] Traceback (most recent call last):
[task 2019-04-17T18:37:01.672Z] File "/builds/worker/checkouts/gecko/taskcluster/mach_commands.py", line 272, in action_callback
[task 2019-04-17T18:37:01.672Z] test=False)
[task 2019-04-17T18:37:01.673Z] File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/actions/registry.py", line 324, in trigger_action_callback
[task 2019-04-17T18:37:01.673Z] cb(Parameters(**parameters), graph_config, input, task_group_id, task_id)
[task 2019-04-17T18:37:01.673Z] File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/actions/create_interactive.py", line 152, in create_interactive_action
[task 2019-04-17T18:37:01.673Z] parameters, modifier=edit)
[task 2019-04-17T18:37:01.673Z] File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/actions/util.py", line 166, in create_tasks
[task 2019-04-17T18:37:01.673Z] decision_task_id,
[task 2019-04-17T18:37:01.673Z] File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/create.py", line 107, in create_tasks
[task 2019-04-17T18:37:01.673Z] f.result()
[task 2019-04-17T18:37:01.673Z] File "/builds/worker/checkouts/gecko/third_party/python/futures/concurrent/futures/_base.py", line 398, in result
[task 2019-04-17T18:37:01.673Z] return self.__get_result()
[task 2019-04-17T18:37:01.673Z] File "/builds/worker/checkouts/gecko/third_party/python/futures/concurrent/futures/thread.py", line 55, in run
[task 2019-04-17T18:37:01.673Z] result = self.fn(*self.args, **self.kwargs)
[task 2019-04-17T18:37:01.673Z] File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/create.py", line 133, in create_task
[task 2019-04-17T18:37:01.673Z] res.raise_for_status()
[task 2019-04-17T18:37:01.673Z] File "/builds/worker/checkouts/gecko/third_party/python/requests/requests/models.py", line 840, in raise_for_status
[task 2019-04-17T18:37:01.673Z] raise HTTPError(http_error_msg, response=self)
[task 2019-04-17T18:37:01.673Z] HTTPError: 400 Client Error: Bad Request for url: http://taskcluster/queue/v1/task/UIlEmMv-SiW8aAIKkKuquA
[taskcluster 2019-04-17 18:37:02.302Z] === Task Finished ===
[taskcluster 2019-04-17 18:37:04.327Z] Unsuccessful task run with exit code: 1 completed in 17.518 seconds

Summary: Intermittent HTTPError: 400 Client Error: Bad Request for url: http://taskcluster/queue/v1/task/MsOmu2NoR427QR8759QNcg → Permafailing create interactive task ac(create-inter) HTTPError: 400 Client Error: Bad Request for url: http://taskcluster/queue/v1/task/MsOmu2NoR427QR8759QNcg

That's not intermittent, it's a bug and probably deserves a backout.

Component: General → Task Configuration
Product: Taskcluster → Firefox Build System

Ah, if it's an action task then it doesn't need a backout.

Maybe from bug 1541859?

Regressed by: 1541859
Flags: needinfo?(aki)
Assignee

Comment 4

2 months ago

Ah, we should probably make that unique.

Flags: needinfo?(aki)
Assignee

Comment 5

2 months ago

https://treeherder.mozilla.org/#/jobs?repo=try&revision=04fa5334db60741af7b50ccad04f600ac476b53a shows my latest patch works.

  • The create-interactive action doesn't specify decision_task_id in util.create_tasks. The child task has a taskGroupId that matches the action task's taskId. We don't want to modify the child task's dependencies in this case, because that results in duplicate dependencies.
  • The add-task action specifies a decision_task_id of the hg-push decision taskId. The child task has a taskGroupId that matches the hg-push decision taskId. The child task also has the action task's taskId in its dependencies, which helps both identify the action that triggered it, and keeps it from running until the action task completes successfully.
Assignee

Updated

2 months ago
Assignee: nobody → aki
Assignee

Comment 6

2 months ago

We only want to append the action TASK_ID to the task dependencies when the taskGroupId doesn't match, otherwise we hit dup dependency errors.

Duplicate of this bug: 1545238

Comment 8

2 months ago
Pushed by asasaki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e95b995fc086
only append action TASK_ID to task deps if taskGroupId doesn't match r=dustin

Comment 9

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.