Closed Bug 1545382 Opened 6 months ago Closed 6 months ago

Tab Navigation does not go through all elements of the Toolbar

Categories

(Firefox :: Keyboard Navigation, defect)

Desktop
All
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox67 --- affected
firefox68 --- affected

People

(Reporter: vlucaci, Unassigned)

References

Details

Attachments

(1 file)

Affected versions

  • 67.0b11
  • 68.0a1

Affected platforms

  • Windows 10x64
  • macOS 10.14
  • Ubuntu 16.04

Steps to reproduce

  1. Launch FF.
  2. Install several random extensions.
  3. Press Tab multiple times.

Expected result

  • The Tab selector goes through all the elements of the Toolbar(back, forward, home, url bar, etc)

Actual result

  • The Tab selector stops at the "View History and more" button and skips to the section below it, instead of going through all the remaining icons from the toolbar(Show Sidebars, FxA icon, different extensions)

Regression range

  • Will return with regression ASAP.

Additional notes

  • There is a workaround for this issue and it is as follows:
    While using tab section, when reaching the View History button, switch to the direction buttons to browse through the remaining elements of the toolbar

(In reply to Vlad Lucaci, QA (:vlucaci) from comment #0)

Actual result

  • The Tab selector stops at the "View History and more" button and skips to the section below it, instead of going through all the remaining icons from the toolbar(Show Sidebars, FxA icon, different extensions)

Additional notes

  • There is a workaround for this issue and it is as follows:
    While using tab section, when reaching the View History button, switch to the direction buttons to browse through the remaining elements of the toolbar

This is the expected outcome of bug 1436086.

Status: NEW → RESOLVED
Closed: 6 months ago
Depends on: 1436086
Resolution: --- → INVALID
Duplicate of this bug: 1550753
You need to log in before you can comment on or make changes to this bug.