Closed Bug 1545407 Opened 1 year ago Closed 1 year ago

[remote-dbg-next] Improve worker debugging workflow

Categories

(DevTools :: about:debugging, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1545650

People

(Reporter: jdescottes, Unassigned)

References

(Blocks 1 open bug)

Details

Follow up to Bug 1505282.

Several issues were raised by a user who tried worker debugging with about:debugging:

  • hard to debug workers with wasm
  • would like to break (and open about:devtools-toolbox tab) as soon as worker starts

I think those needs will be better served by the Debugger panel directly rather than by opening a dedicated toolbox for the worker. But if that's the case maybe we should hide the webworkers from about:debugging to encourage users to first inspect the Tab where the worker runs and then use the Debugger.

Duplicate of this bug: 1505282

would like to break (and open about:devtools-toolbox tab) as soon as worker starts

Pausing on worker creation is a feature request tracked in bug 1545650 (might be the worker panel or handled by a custom entry in the event breakpoints panel, bug 1526079).

hard to debug workers with wasm

Lars, is this still an issue with bug 1523262 and bug 1520698?

Flags: needinfo?(lhansen)

I believe wasm debugging in workers is now possible, after the fix that made the wasm code visible. (I believe I fixed a tricky bug on Android using that functionality.)

Flags: needinfo?(lhansen)

Thanks for the updates Harald and Lars, will close this one as duplicate of bug 1545650.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1545650
You need to log in before you can comment on or make changes to this bug.