If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

clicking OK in Wallet Contents password dialogue fails

VERIFIED DUPLICATE of bug 15461

Status

()

Toolkit
Form Manager
P3
normal
VERIFIED DUPLICATE of bug 15461
18 years ago
9 years ago

People

(Reporter: Paul MacQuiddy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If you have a password set and try to go to the Wallet Contents views, the OK
button is visible, but clicking on it doesn't do anything, and the browser is
essentially hung since it is a modal dialogue. To reproduce

1. Launch apprunner and capture a form. Make sure to set a not blank password.
2. Shutdown and re-launch.
3. Goto Edit - Wallet - Wallet Contents
4. Enter password and press OK.

Results: Clicking on OK does nothing, and you can't dismiss the window.

This happens on Linux and Windows builds, 10/4.

This same symptom occurs when you try to do a safe form fill and the password
dialogue is brought up. Single signon doesn't have this problem.
(Reporter)

Comment 1

18 years ago
This happens in M10 builds, linux and windows. If you have a password set, you
can not view Wallet Contents or use Autofill. This got broken sometime between
the time we branched M10 and Friday night.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Comment 2

18 years ago
Do you think this is related to bug 15461?  I can't even get started enough to
initially set a password because of that bug.  Are you able to click OK in the
set-password dialog?
(Reporter)

Comment 3

18 years ago
Actually, I've found that if I use a single-signon page to set my password, then
I can do it successfully. If I use a capture form page to initially set my
password, then no luck. Strange...

But that goes with the current state of the builds, single-signon is OK, Wallet
is not Ok.

Comment 4

18 years ago
How about trying to repeatedly click on OK very rapidly when you get the
wallet-contents dialog.  Does it dismiss then?

I just tried it, and that is what I observed.  At first it appeared as though OK
was doing nothing and I couldn't dismiss the window.  But after enough
mouseclicks the window did dismiss.

If you observe that as well, then this is a dup of 15461.  Let me know.

Updated

18 years ago
Target Milestone: M11 → M10

Comment 5

18 years ago
paulmac, can you try this on all platforms with lastest M10.  If it works as
morse describes, we can release note.

Comment 6

18 years ago
If it works as I described on M10, then we have a bigger problem than just
wallet.  In my tree it is doing the same thing for preferences also.  See bug
15461.
(Reporter)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

18 years ago
Steve, I see the same behaviour you describe, marking this as a duplicate of
15461. The fast click trick doesn't seem to work on Linux, however, so a simple
release note would not suffice.

*** This bug has been marked as a duplicate of 15461 ***
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: paulmac → form.manager
Target Milestone: M10 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.