Closed Bug 1545537 Opened 5 months ago Closed 5 months ago

Perma tier2 tests/jit-test/jit-test/tests/debug/bug1106719.js | adb_returncode=139 (code 139, args "--baseline-eager") [0.2 s]

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: tcampbell)

References

(Depends on 1 open bug, Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [retriggered][stockwell needswork:owner])

Attachments

(2 files)

#[markdown(off)]
Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=241204730&repo=autoland

https://queue.taskcluster.net/v1/task/Xdoa1i4SRzq86hyzQ_Ha1Q/runs/0/artifacts/public/logs/live_backing.log

17:43:21 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1106719.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s]
17:43:22 INFO - adb_returncode=139
17:43:22 INFO - Segmentation faultadb_returncode=139
17:43:22 INFO - Segmentation faultExit code: 139
17:43:22 INFO - FAIL - debug/bug1106719.js
17:43:22 WARNING - TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/debug/bug1106719.js | adb_returncode=139 (code 139, args "--baseline-eager") [0.2 s]
17:43:22 INFO - INFO exit-status : 139
17:43:22 INFO - INFO timed-out : False
17:43:22 INFO - INFO stdout > adb_returncode=139
17:43:22 INFO - INFO stdout > Segmentation fault
17:43:22 INFO - INFO stderr 2> adb_returncode=139
17:43:22 INFO - INFO stderr 2> Segmentation fault
17:43:22 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1106719.js | Success (code 3, args "--no-baseline --no-ion --more-compartments") [0.1 s]
17:43:22 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107525.js | Success (code 3, args "") [0.1 s]
17:43:22 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107525.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.2 s]
17:43:22 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107525.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.4 s]
17:43:23 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107525.js | Success (code 3, args "--baseline-eager") [0.3 s]
17:43:23 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107525.js | Success (code 3, args "--no-baseline --no-ion --more-compartments") [0.3 s]
17:43:23 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107913.js | Success (code 3, args "") [0.2 s]
17:43:23 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107913.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.2 s]
17:43:24 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107913.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s]
17:43:24 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107913.js | Success (code 3, args "--baseline-eager") [0.2 s]
17:43:24 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107913.js | Success (code 3, args "--no-baseline --no-ion --more-compartments") [0.2 s]
17:43:24 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1108556.js | Success (code 3, args "") [0.2 s]
17:43:24 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1108556.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.2 s]
17:43:25 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1108556.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s]
17:43:25 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1108556.js | Success (code 3, args "--baseline-eager") [0.1 s]
17:43:25 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1108556.js | Success (code 3, args "--no-baseline --no-ion --more-compartments") [0.2 s]
17:43:25 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1109328.js | Success (code 0, args "") [0.2 s]

Summary: Intermittent tests/jit-test/jit-test/tests/debug/bug1106719.js | adb_returncode=139 (code 139, args "--baseline-eager") [0.2 s] → Perma tier2 tests/jit-test/jit-test/tests/debug/bug1106719.js | adb_returncode=139 (code 139, args "--baseline-eager") [0.2 s]
Priority: P5 → --
Duplicate of this bug: 1546163

Looking at the logcat file I see "MOZ_Assert: Assertion failure: [unhandlable oom] Could not allocate ObjectGroup in EnsureTrackPropertyTypes". The test is marked as allowing 'unhandleable-oom' but the test harness is broken here.

Bug 1511618 ran into the same problem for 'crash' annotations. I'll try to replicate that patch for this similar case.

Assignee: nobody → tcampbell
Flags: needinfo?(tcampbell)
See Also: → 1511618

Thanks Ted. There are 40 total failures in the last 7 days on android-hw-p2-8-0-android-aarch64 opt.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=242102374&repo=mozilla-inbound&lineNumber=2255

17:14:53 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1106719.js | Success (code 3, args "") [0.1 s]
17:14:53 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1106719.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.2 s]
17:14:53 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1106719.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.2 s]
17:14:54 INFO - adb_returncode=139
17:14:54 INFO - Segmentation faultadb_returncode=139
17:14:54 INFO - Segmentation faultExit code: 139
17:14:54 INFO - FAIL - debug/bug1106719.js
17:14:54 WARNING - TEST-UNEXPECTED-FAIL | tests/jit-test/jit-test/tests/debug/bug1106719.js | adb_returncode=139 (code 139, args "--baseline-eager") [0.2 s]
17:14:54 INFO - INFO exit-status : 139
17:14:54 INFO - INFO timed-out : False
17:14:54 INFO - INFO stdout > adb_returncode=139
17:14:54 INFO - INFO stdout > Segmentation fault
17:14:54 INFO - INFO stderr 2> adb_returncode=139
17:14:54 INFO - INFO stderr 2> Segmentation fault
17:14:54 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1106719.js | Success (code 3, args "--no-baseline --no-ion --more-compartments") [0.3 s]
17:14:54 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107525.js | Success (code 3, args "") [0.2 s]
17:14:54 INFO - TEST-PASS | tests/jit-test/jit-test/tests/debug/bug1107525.js | Success (code 3, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.3 s]

Whiteboard: [retriggered] → [retriggered][stockwell needswork:owner]

Bob, it seems the jit-test harness doesn't handle some of our expected crash formats because that data is sent to logcat instead of stdio. For this bug I'm simply going to disable the test on Android, but I am wondering if we should be doing anything about this to fix properly. It seems like a long standing issue but expected unhandlable-oom is rare in the test case and usually is variable with build.

https://searchfox.org/mozilla-central/rev/ec489aa170b6486891cf3625717d6fa12bcd11c1/mfbt/Assertions.h#161-163

Flags: needinfo?(bob)

Looks like this is a known issue and there is already a bug open to address this in Bug 1532654.

Depends on: 1532654
Flags: needinfo?(bob)

Patch posted on Bug 1532654. Will close this bug when it lands in next few days.

Disable certain jit-tests until Bug 1532654 is fixed.

Depends on D28842

Change of plans. I'm just going to disable the tests.

Pushed by tcampbell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16aee8bebc47
Add 'android' as a jsshell buildConfiguration property. r=sstangl
https://hg.mozilla.org/integration/autoland/rev/9c775e06b5f7
Disable some jit-tests on android due to harness issues. r=sstangl
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.