keyboard shortcuts in menus should be in their own column

VERIFIED DUPLICATE of bug 38367

Status

()

Core
XUL
--
minor
VERIFIED DUPLICATE of bug 38367
16 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Keyboard shortcuts in menus should be left-aligned and in their own column, like
they are in native Windows apps.  They are currently right-aligned, and part of
the shortcut for one menu item can be directly below the name of another menu
item.  This bug makes the View menu in navigator ugly, and makes the View menu
in mail hard to read.

We should allow menu items that are page titles to extend over both columns. 
Page titles appear in the Go, Bookmarks, and Window menus.  When long page
titles are present, the keyboard-shortcuts column should be pushed to the right
as far as possible without causing the menu to expand.  (I've always wondered by
IE hides the keyboard shortcuts for adding and organizing favorites.  Now I know.)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 38367 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
indeed, a duplicate
--> verified

Comment 3

16 years ago
trying again.. maybe my arrow wasnt long enough ;)
-------> verified
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.