Problem with finding user profile after the location of system user profile was changed

VERIFIED FIXED

Status

Core Graveyard
Profile: BackEnd
VERIFIED FIXED
16 years ago
2 years ago

People

(Reporter: Andy C. Brandt, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I use Mozilla on a W2K Prof. system that is (unfortunately) to some extent 
administered by the domain administrators. Recently a script has copied all the 
contents of my profile from C:\Documents and settings to D:\Documents and 
settings and then removed the files from C: drive. Some records in the system 
registry were changed also in such a way, that the system now recognizes that 
my profile is on the D: drive. Most applications also do.

However, I’ve had a problem with Mozilla. As the result of the changes the 
Mozilla folder kept in the Application Data subfolder of the profile has moved 
too. However, Mozilla failed to notice it and when I start it the profile 
creation dialog appears. When I try to create a new profile it does however say 
that it would create the files by default in the new location (on the D: drive 
in the Application Data\Mozilla folder). So – to some extent it does recognize 
that the system user profile location has changed. 

I think that the problem may come from saving the absolute path to the Mozilla 
profile upon its creation. Probably the path relative to the system user 
profile location should be saved if the profile is created in its default 
location.

Appart from fixing that problem some help in regaining access to my e-mail and 
bookmarks would be great.

Build ID: 2002053012
(Reporter)

Comment 1

16 years ago
I checked the registry.dat file and indeed the path to my old profile is hard-
saved there twice (with C:\Documents and settings\... in the front of it). I 
tried to use a hex editor to change that C: into D:, but it didn't work 
(Mozilla won't start after I changed that file). Unfortunately, there is no 
tool to edit that file and the profile manager doesn't allow editing this path 
per profile.

(BTW - Mozilla reads registry.dat from its folder in the Application Data in 
the system user profile on D: drive now).
(Assignee)

Comment 2

16 years ago
Dup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

16 years ago
Yeah, great that it is a duplicate, but I stil don't know what to do to get my 
profile data back.

Comment 4

16 years ago
CCing gbush. Grace, do you know of a way Andy can get his profile data back?
This does look familiar. I'll try to track down the dupe in case there's a
workaround on it.

Comment 5

16 years ago
Could this be related to bug 150453 (or related bugs listed on that bug)?

Comment 6

16 years ago
What I have found  to work.
first make a backup of current working profile(for safety sake)
In Mozilla, create a new profile which will be stored in d:\documents and 
settings\yourwinprofile\application 
data\mozilla\profiles\newprofile\abcdefgh.slt
The registry will contain this path to the profile.
Copy all the files in your saved working profile old .slt directory to this 
directory(abcdefgh.slt)
Depending on where mail saved, some of the prefs.js prefs  may need editing. 

I have tried this on my system and got it to work, but have found others who 
have had other problems to resolve.
Some items may be imported (book marks, address books)
(Reporter)

Comment 7

16 years ago
Thanks for your concern but somehow (with help from a guy on mozilla’s IRC) 
I’ve managed to get my profile back. I had to create a new profile; then 
overwrite everything inside the random-named folder with the contents of my old 
profile, then delete XUL.mfl, run a search on files to see where the paths are 
hard-coded (included prefs.js and some .dat files) and edit these paths by hand 
using a text editor. All in all it took me two hours to get my profile back 
(also because my first file search didn’t find all the occurrences of paths to 
old profile as file paths are kept in different formats – sometimes using \\ to 
delimit the directories, sometimes using /). 

During that process I came to conclusion that Mozilla profile is a mess, that 
it should be reorganized in a more logical way and with a decent front end 
added that would allow normal users to adjust their profiles as needed.
(Assignee)

Comment 8

16 years ago
See bug 137006. Using relative paths, you would not have had to fix all those
paths when moving the contents of the profile dir.

Comment 9

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.