Closed Bug 1545727 Opened 2 years ago Closed 8 months ago

The viewer for JSON responses is completely inaccessible

Categories

(DevTools :: JSON Viewer, defect, P3)

67 Branch
defect

Tracking

(firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: dickson.tan.2013, Assigned: dickson.tan.2013, NeedInfo)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. Visit any API endpoint that returns JSON, such as the root GitHub endpoint
  2. Attempt to navigate through the JSON tree with the NVDA screen reader

Actual results:

The contents of the tree view cannot be read with NVDA, except through advanced object navigation techniques. Using the arrow keys to navigate through the tree doesn't work. First letter navigation also doesn't work.

Expected results:

The contents of the tree are accessible, and is keyboard navigatable. Up/down arrows moves you through the tree's contents, and left and right arrows expand / collapse nodes. First letter navigation moves you to the next node, who's key corresponds to the letter just pressed.

Component: Untriaged → JSON Viewer
Product: Firefox → DevTools

Make the JSON tree view more accessible.

  1. Automatically set focus to the first node on initial focus. Previously, the only way to interact with the tree view through the keyboard was to click on a node so that subsequent key presses would register.
  2. Fix inaccurate aria-level and aria-expanded attributes causing confusing announcements for screen reader users.
  3. Previously, pressing left arrow the first time on a leaf child node would not move focus to its parent, but subsequent tries would work. This has been fixed.
  4. Implement first-letter navigation for quick movement via keyboard.
Assignee: nobody → dickson.tan.2013
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a52a8f4ab189
make the JSON tree viewer more accessible. r=Honza
Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/41f8b0b21560
make the JSON tree viewer more accessible. r=Honza
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
Regressions: 1641719
Duplicate of this bug: 1443507
You need to log in before you can comment on or make changes to this bug.