[Dedicated Profiles] The restart buttons don't work after the page refresh prompts to restart the browser

VERIFIED FIXED in Firefox 67

Status

()

defect
--
major
VERIFIED FIXED
a month ago
a month ago

People

(Reporter: cbaica, Assigned: mossop)

Tracking

(Regression, {regression})

68 Branch
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 verified, firefox68 verified)

Details

Attachments

(1 attachment)

[Affected versions]:

  • Fx68.0a1

[Affected platforms]:

  • macOS 10.14
  • Ubuntu 18.04
  • Windows 10 x64

[Pre-requisites]:
Have at least 2 different installs of the latest nightly with DP feature.

[Steps to reproduce]:

  1. Launch the first build and go to the about:profiles page.
  2. Leave that build running with the about:profiles page loaded.
  3. Launch the second build.
  4. Go back to the first build about:profiles page and refresh it (click the refresh button or hit F5 on the keyboard).
  5. Click the 'Restart Normaly...' button or 'Restart with Addons disabled'.

[Expected result]:

  • The buttons don't work.

[Actual result]:

  • The buttons should restart Firefox.

[Regression range]:

[Additional notes]:

  • The buttons work without any issues if no refresh is done on the page.
  • I would say this will block the uplift to beta

Dave can you please take a look?

Flags: needinfo?(dtownsend)
Assignee

Updated

a month ago
Assignee: nobody → dtownsend
Flags: needinfo?(dtownsend)

Comment 3

a month ago
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fd06c4854aba
about:profiles buttons should be initialised when the UI loads, not everytime the UI is refreshed. r=jaws

Comment 5

a month ago
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6ffe4f5a3c47
about:profiles buttons should be initialised when the UI loads, not everytime the UI is refreshed. r=jaws

Comment 6

a month ago
bugherder
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Tested using Fx68.0a1 buildID: 20190421212635 on macOS 10.14, Ubuntu 18.04 LTS and Windows 10 x64. The buttons function without any issues.

Status: RESOLVED → VERIFIED

Comment on attachment 9059487 [details]
Bug 1545736: about:profiles buttons should be initialised when the UI loads, not everytime the UI is refreshed. r=Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: Users won't be able to restart Firefox from about:profiles if the profiles database is outdated.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1529879
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple fix to the UI initialisation code.
  • String changes made/needed: None
Flags: needinfo?(dtownsend)
Attachment #9059487 - Flags: approval-mozilla-beta?

Comment on attachment 9059487 [details]
Bug 1545736: about:profiles buttons should be initialised when the UI loads, not everytime the UI is refreshed. r=Gijs

Verified by QA on nightly + automated tests, uplift approved for 67 beta 14, thanks.

Attachment #9059487 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

The issue is verified fixed using Fx67.0b14 buildID: 20190423190209 (intermediary build) on Ubuntu 18.04, macOS 10.14 and Windows 10 x64. The buttons work correctly on the refreshed about:profiles page.

You need to log in before you can comment on or make changes to this bug.