Closed Bug 1545739 Opened 2 years ago Closed 1 year ago

Indicate that resources might be blocked

Categories

(DevTools :: Netmonitor, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1333994

People

(Reporter: Honza, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image image.png

This is a follow up for bug 1151368


The Network panel should indicate that there might be some resources manually blocked. We might want to add an icon next to the Network tab (see screenshot) that appears when the user manually blocks a resource. There should be a tooltip saying "Requests may be blocked"

Honza

Harald, just opened this bug so we have room for discussion.
Any inputs?
Could this be the first iteration?

Honza

Flags: needinfo?(hkirschner)
Type: defect → enhancement
Priority: -- → P3

I like Chrome's warning as stop gap, which works for any tab that has some potential-footgun state.

The warning should show when throttling or request blocking is active (which seems to be the same in Chrome). A tooltip on the tab should provide the reason.

The benefit of showing the icon on top, within, or combined with the existing Network tab icon is that we don't shift the tab layout around like Chrome does when showing/hiding the icon. We could even have some fun with an animation (like the tracking protection shield), to focus users on the icon when the right options are toggled.

Started capturing those thoughts and more in a UX issue: https://github.com/firefox-devtools/ux/issues/60

Flags: needinfo?(hkirschner)

Requirements:

  1. The warning should show when throttling or request blocking is active
  2. A tooltip on the tab should provide the reason.

Final design: https://github.com/firefox-devtools/ux/issues/60#issuecomment-542921002

Implementation could use CSS to over the icon, more details in https://github.com/firefox-devtools/ux/issues/60#issuecomment-517164667

Landed in bug 1333994.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333994
You need to log in before you can comment on or make changes to this bug.