On "Secure Connection Failed" screen "Learn more ..." broken

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
2 months ago
9 days ago

People

(Reporter: alberts, Assigned: johannh)

Tracking

({regression})

68 Branch
Firefox 68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 months ago

Ran into "Secure Connection Failed" while trying to load https://www.azlyrics.com/ - I assume server misconfigured, with Safari and Opera I get errors as well.

Clicking on the "Learn more…" button doesn't do anything and it shows me the courser: text instead of the cursor: pointer. Here the code from the link:

<a xmlns="http://www.w3.org/1999/xhtml"
   id="learnMoreLink" target="new"
   data-telemetry-id="learn_more_link">Learn more…</a>
Assignee

Comment 1

2 months ago

Ah, so we're missing to set the link on that element. Unfortunately we would need the error type of that website to try and reproduce, but the website is working again. You don't happen to know why the secure connection failed?

Flags: needinfo?(albert)
Reporter

Comment 2

2 months ago

Sorry Johann, I don't and I wasn't aware that this piece of info was required for a fix of that error page. Will keep it in mind for next time and try to update this ticket if I stumble upon the error and link again.

Flags: needinfo?(albert)

The priority flag is not set for this bug.
:wleung, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(wleung)
Assignee

Comment 4

Last month

Still looking into this. Flod had some STR, I believe.

Thanks!

Flags: needinfo?(wleung) → needinfo?(francesco.lodolo)

I just went to https://badssl.com/ and selected expired
https://expired.badssl.com/

Click on the link returns

TypeError: doc.body.getAttribute(...) is null
NetErrorChild.jsm:806:30

https://searchfox.org/mozilla-central/source/browser/actors/NetErrorChild.jsm#806

Touched in bug 1484255.

I'm seeing this on Italian build of nightly (68.0a1 (2019-05-08) (64 bit))

Flags: needinfo?(francesco.lodolo)

Adding some more info from IRC conversation with kwan (thanks!): the error page I see is completely different from en-US (no yellow border).

I also see this error in console when it loads

date value is not finite in DateTimeFormat.format() NetErrorChild.jsm:280
    dateTimeFormatFormatToBind self-hosted:2628
    dateTimeFormatFormatToBind self-hosted:1003
    _setTechDetails resource:///actors/NetErrorChild.jsm:280
    onCertErrorDetails resource:///actors/NetErrorChild.jsm:359
    receiveMessage resource:///actors/NetErrorChild.jsm:646
    receiveMessage resource://gre/modules/ActorManagerChild.jsm:165

which leads to bug 1530335. So, what I'm seeing is a different regression (same symptoms).

Assignee

Comment 7

Last month

I'm not sure when this actually regressed but I know how to fix it.

Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: -- → P1
Assignee

Comment 8

Last month

Can't reproduce on Beta.

Assignee

Updated

Last month
Keywords: regression
Assignee

Updated

Last month
Duplicate of this bug: 1550766

Comment 11

Last month
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f8d305fa503b
Don't use validity.not{After,Before}LocalTime for parsing date information in NetErrorChild.jsm. r=prathiksha

Comment 12

Last month
bugherder
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

This is fixed for me in the latest Nightly - thanks!

Assignee

Comment 14

Last month

Thanks!

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-68b-p2]
You need to log in before you can comment on or make changes to this bug.