Closed Bug 1545752 Opened 2 years ago Closed 5 months ago

The Picture-in-Picture window opens on main monitor even if the browser is opened on the secondary monitor

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

68 Branch
defect

Tracking

()

VERIFIED FIXED
84 Branch
Tracking Status
firefox84 --- verified

People

(Reporter: george.craciun, Assigned: baumga91)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

STR:

0.Ensure media.videocontrols.picture-in-picture.enabled is set to true and another monitor is connected

  1. Open Firefox on the second monitor
  2. Visit https://youtube.com and play a video
  3. Right-click on the video, and choose Picture in Picture

ER:

The Picture-in-Picture window should open on the second monitor on the right bottom corner

AR:

The Picture-in-Picture window opens on the main monitor on the right bottom corner

Reproduced on latest Nightly 71 and Beta 70.0b7 on Windows 10 x64.

Additional note:
PiP window will open on the second monitor (where the browser was opened) when the browser is in windowed mode.

I love the feature! I've got this same problem, but it happens even when I have Firefox opened on the main screen, and PiP shows in the bottom-right corner of the secondary display. From what I see the main screen in Windows settings has number "2", so maybe that's some clue.

Duplicate of this bug: 1630857

I cannot reproduce this bug on macOS 10.15.6 using Firefox 80.0.1 or Nightly 83.0a1. Getting expected behavior on both versions where the PIP window opens on the monitor the browser is on.

Bug still occurs on Firefox 81.0 (64 bits) on Windows 10.

Video recorded 1 minute ago: https://www.youtube.com/watch?v=T24crlngLoY

Assignee: nobody → baumga91

Manual test to recreate the error on Windows 10.
Two monitors are needed for this.

  1. Open Firefox on the right browser and make sure the browser is maximized.
  2. Find a video and click the Picture-in-Picture button to open a Picture-in-Picture window

Expected behavior:
The Picture-in-Picture window will open on right monitor. (The monitor with the Firefox browser)

Unexpected behavior:
The Picture-in-Picture window will open on the left monitor.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/924ed82a2388
The Picture-in-Picture window opens on correct monitor. r=mconley
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

Reproduced the initial issue in release version 83.0 using Windows 10.
Verified - Fixed in latest Beta 84.0b3 and latest Nightly 85.0a1 (build id: 20201118215158). The Picture-in-Picture window is opened on right monitor (The monitor with the browser).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.