Closed Bug 1545791 Opened 4 years ago Closed 3 years ago

country selector is not shown - user is locked at position of website

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

66 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: klaus.luppert, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [tp-needsrepro])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

I am in Germany, just in case it matters to reproduce this issue.

Open this specific site:
https://www.ramtrucks.com/

If you watched the site in the past it already, it may be necessary to delete the cookie or use a private tab/window to see the issue.

Actual results:

The site shows up, but it only gets dark and there is no way I can select the country and I am locked there.

Expected results:

It should get dark, but also a "window" in the middle of the screen should have been opened like it happens in Microsoft Edge called "choose your site" where the user can select his/her country.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Hi,

I have managed to reproduce this issue on latest FF release (66.0.3), latest Nightly build (68.0a1 (2019-04-22)) using Windows10 and Ubuntu 18.04
The issue is reproducible in private mode, even with new clean profile, but if restart firefox in safe mode (with Add-ons disabled) the problem is no longer occur, the window "choose your site" appear, select country, than the user can continue navigation in the site.

I'm going to set a component so developers can take a look at it. If this is not the right component, please feel free to move it to a more appropriate one.

Thank you for your report.

Component: Untriaged → Private Browsing
Blocks: tp-breakage
Status: UNCONFIRMED → NEW
Component: Private Browsing → Tracking Protection
Ever confirmed: true
Priority: -- → P3
Whiteboard: [tp-needsrepro]

Any news to this?

Component: Protections UI → Privacy: Anti-Tracking
Product: Firefox → Core

The country selector is properly showing up for me now with strict tracking protection on, so this seems fixed.

In fact it understandably seems like the same country selector used by Jeep.com in bug 1531225, which also works for me now.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.