Closed Bug 1545802 (trailhead-firstrun) Opened 8 months ago Closed 5 months ago

[META] Trailhead Desktop First Run

Categories

(Firefox :: Messaging System, enhancement, P1, major)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- unaffected
firefox67.0.1 + fixed

People

(Reporter: jdavis, Unassigned)

References

(Depends on 1 open bug, Blocks 4 open bugs)

Details

(Keywords: meta)

User Story

PRD: https://docs.google.com/document/d/1OaZWbRSl5jtXWatxfkPpAuhKK7Kkep5KAm_OtfNJogE/edit#

Tech documentation: https://docs.google.com/document/d/1t3dDeaAKwLpH39a2LZ7xYzX4n17w-IGiTUpk0xU9LdY/edit#

Designs: https://mozilla.invisionapp.com/share/ZFRRK6ZSQW9#/screens/360574173

Tracking the work needed to support Trailhead Desktop First Run experience.

Type: defect → enhancement
User Story: (updated)
Blocks: 1545829
Depends on: 1545846
Depends on: 1545848
Depends on: 1545849
Depends on: 1545850
Priority: -- → P1
Depends on: 1546683
Blocks: 1546826
Depends on: 1547016
Depends on: 1547061
Depends on: 1547062
Depends on: 1547064
Depends on: 1547065
Depends on: 1547066
Depends on: 1547744
Depends on: 1547746
Depends on: 1547748
Depends on: 1547830
Depends on: 1548052
Depends on: 1548065
Depends on: 1548072

Just noting merge conflicts when uplifting to 67:

bin/render-activity-stream-html.js

-     <div id="footer-snippets-container" />${options.noscripts ? "" : scriptTag}
 -    <div id="footer-asrouter-container"></div>${options.noscripts ? "" : scriptRender}
++    <div id="footer-asrouter-container"></div>${options.noscripts ? "" : scriptTag}

content-src/asrouter/asrouter-content.jsx

 -        </>,
 +        </React.Fragment>,
-         this.portalContainer
+         shouldRenderInHeader ? this.headerPortal : this.footerPortal

content-src/asrouter/components/ModalOverlay/ModalOverlay.jsx

-export const ModalOverlayWrapper = props => (<>
+export const ModalOverlayWrapper = props => (<React.Fragment>
…
-</>);
+</React.Fragment>);

content-src/asrouter/templates/Trailhead/Trailhead.jsx

-    return (<>
+    return (<React.Fragment>
…
-    </>);
+    </React.Fragment>);

content-src/styles/_theme.scss

 -  &[lwt-newtab-brighttext] {
 +  &[lwt-newtab-brighttext]:not(.force-light-theme) {
Depends on: 1548267
Depends on: 1548268
User Story: (updated)
Depends on: 1548503
Depends on: 1548504
Depends on: 1548743
Depends on: 1548832
Depends on: 1549779
Depends on: 1549784
Depends on: 1549846
Depends on: 1549895
Depends on: 1549906
Depends on: 1550098
Depends on: 1550217
Depends on: 1550438
Depends on: 1550572
Depends on: 1550614
Depends on: 1550642
Depends on: 1550649
Depends on: 1550858
Depends on: 1550861
Depends on: 1550176
Depends on: 1551540
Depends on: 1551677
Depends on: 1551832
Depends on: 1551951
Blocks: 1552280
Blocks: 1552282
Blocks: bugzy-epic
Depends on: 1553205
Depends on: 1553322
Depends on: 1553391
Depends on: 1554212
No longer depends on: 1554666
No longer depends on: 1554704
Depends on: 1554102
Alias: trailhead-firstrun
Depends on: 1554704
No longer blocks: 1552280
Depends on: 1552280
Depends on: 1554666
Blocks: 1552285
Depends on: 1554282
Duplicate of this bug: 1552282
Summary: [META] Trailhead Desktop First Run in 67 → [META] Trailhead Desktop First Run in 67+
No longer blocks: 1552285
Depends on: 1552285
Depends on: 1549653
Depends on: 1555692
Depends on: 1556276
Depends on: 1558284
Depends on: 1560065
Component: Activity Streams: Newtab → Messaging System
Blocks: msrouter
Summary: [META] Trailhead Desktop First Run in 67+ → [META] Trailhead Desktop First Run
Depends on: 1561403
No longer depends on: 1554282
No longer depends on: 1554704
No longer depends on: 1558284
No longer depends on: 1560065
No longer depends on: 1556276
No longer depends on: 1561660
No longer depends on: 1554666
No longer depends on: 1552285

Closing this as resolved as this has shipped for Trailhead. All future bugs will be tracked via https://bugzilla.mozilla.org/show_bug.cgi?id=1563345

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.