Closed Bug 1545838 Opened 8 months ago Closed 8 months ago

Update Fennec's AMO URL (again)

Categories

(Firefox for Android :: Add-on Manager, defect, P1)

Unspecified
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox66 --- wontfix
firefox67 --- verified
firefox68 --- verified

People

(Reporter: cpeterson, Assigned: ateslovan)

References

Details

(Whiteboard: [bcs:p1])

Attachments

(1 file)

Petru, I see you just landed the new AMO URL and title for bug 1544525. Sorry to keep changing the feature requirements, but the AMO team has a new recommended AMO URL:

https://addons.mozilla.org/firefox/collections/4757633/mob/?page=1&collection_sort=-popularity

The URL they had recommended in bug 1544525 sorts the add-ons by "newest first". The new URL above sorts the add-ons by popularity. The "newest first" sort order is not meaningful to users. The popularity sort order will guide users to the most relevant add-ons first.

Flags: needinfo?(petru.lingurar)
Assignee: petru.lingurar → andrei.teslovan
Status: NEW → ASSIGNED
Keywords: checkin-needed
Flags: qe-verify+

Andrei, patch failed to land with reason:

We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

(255, 'applying /tmp/tmpyizcAp\npatching file mobile/android/app/mobile.js\nHunk #1 FAILED at 211\n1 out of 1 hunks FAILED -- saving rejects to file mobile/android/app/mobile.js.rej\nabort: patch failed to apply', '')

Flags: needinfo?(andrei.teslovan)

Rebased on top of the latest central. Please try again.

Flags: needinfo?(andrei.teslovan) → needinfo?(nbeleuzu)
Keywords: checkin-needed
Flags: needinfo?(nbeleuzu)
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Andrei, we will want to uplift your AMO URL fix to Fennec 67 Beta, but we need to make sure Petru's AMO patches from bug 1544525 landed on Beta first.

Comment on attachment 9059813 [details]
Bug 1545838 - Update Fennec's AMO URL; r?petru

Beta/Release Uplift Approval Request

  • User impact if declined: outdated experience for the AMO addons
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open about:addons
    Press "Browse Firefox’s Recommended Extensions"
    Check if the URL opened is "https://addons.mozilla.org/firefox/collections/4757633/mob/?page=1&collection_sort=-popularity"
  • List of other uplifts needed: Bug 1544525
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky - it's just a simple URL change
  • String changes made/needed: No
Attachment #9059813 - Flags: approval-mozilla-beta?
Flags: needinfo?(petru.lingurar)
QA Whiteboard: [qa-triaged]

Verified as fixed on latest Nightly build (68.0a1 - 04/23). The URL "https://addons.mozilla.org/firefox/collections/4757633/mob/?page=1&collection_sort=-popularity" is opened after "Browse Firefox's Recommended Extensions" is tapped.

Bug 1544525 is verified as well, on Nightly.

QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Comment on attachment 9059813 [details]
Bug 1545838 - Update Fennec's AMO URL; r?petru

Low risk, uplift approved for 67 beta 14, thanks.

Attachment #9059813 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hello,

I have verified the issue on Beta 67.0b14 using OnePlus A3000 (Android 6.0.1) and Samsung Galaxy S8+ (Android 8.0.0).
The correct link is opened after taping the "Browse Firefox's Recommended Extensions".

Bug 1544525 is verified as well on Beta.

Due to my findings, I'll mark this issue as verified in Firefox 67.

Status: RESOLVED → VERIFIED
Depends on: 1578614
You need to log in before you can comment on or make changes to this bug.