Wrong install.js and platform.jar

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: gp, Assigned: rpmdisguise-nave)

Tracking

Details

(Reporter)

Description

17 years ago
Dear Henrik.

Ther is a problem in the install.js (line 107.) Change _ to -

Also change the filenames from ie. da_mac.jar to da-mac.jar.

It is very annoing to do it by hand.
And if it isen't done the files will have wrong permissions in Linux because it
is casesensitive.

Gunner Poulsen.
(Reporter)

Comment 1

16 years ago
The problem is stil pressent in beta9.

The file names are correct but the files still get the wrong rights:

root]# ls -all /usr/lib/mozilla-1.0.0/chrome/
totalt 4644
drwxr-xr-x    3 root     root         4096 jul  6 11:49 .
drwxr-xr-x    9 root     root         4096 jun 27 11:31 ..
-rw-r--r--    1 root     root       106693 jun  8 00:30 chatzilla.jar
-rw-r--r--    1 root     root       196822 jun  8 00:30 chromelist.txt
-rw-r--r--    1 root     root        38902 jul  6 11:49 chrome.rdf
-rw-r--r--    1 root     root       291073 jun  8 00:30 classic.jar
-rw-r--r--    1 root     root       887074 jun  8 00:30 comm.jar
-rw-r--r--    1 root     root         3576 jun  8 00:30 content-packs.jar
-r--------    1 root     root       603141 jul  6 00:05 da-DK.jar
-r--------    1 root     root         3473 jul  6 00:05 da-mac.jar
-r--------    1 root     root         4355 jul  6 00:05 da-unix.jar
-r--------    1 root     root         6027 jul  6 00:05 da-win.jar
-rw-r--r--    1 root     root         2758 jun  8 00:30 en-mac.jar
-rw-r--r--    1 root     root         4680 jun  8 00:30 en-unix.jar
-rw-r--r--    1 root     root       683232 jun  8 00:30 en-US.jar
-rw-r--r--    1 root     root         3855 jun  8 00:30 en-win.jar
-rw-r--r--    1 root     root        21390 jun  8 00:29 forms.jar
-rw-r--r--    1 root     root        12060 jun  8 00:30 help.jar
-rw-r--r--    1 root     root       191085 jun  8 00:30 inspector.jar
-rw-r--r--    1 root     root        42069 jul  6 11:49 installed-chrome.txt
-rw-r--r--    1 root     root       467203 jun  8 00:30 messenger.jar
-rw-r--r--    1 root     root       550643 jun  8 00:30 modern.jar
drwxr-xr-x    8 root     root         4096 jun 27 11:31 overlayinfo
-rw-r--r--    1 root     root          485 jun  8 00:30 pipnss.jar
-rw-r--r--    1 root     root        92213 jun  8 00:30 pippki.jar
-rw-r--r--    1 root     root       227220 jun  8 00:30 toolkit.jar
-rw-r--r--    1 root     root        22892 jun  8 00:30 US.jar
-rw-r--r--    1 root     root       175327 jun  8 00:30 venkman.jar
The MozillaTranslator component is moving to the Mozilla Localisations product.
Product: Browser → Mozilla Localizations
Version: other → unspecified
(Assignee)

Comment 3

12 years ago
(In reply to comment #1)
> The problem is stil pressent in beta9.
> 
> The file names are correct but the files still get the wrong rights:
> 
> root]# ls -all /usr/lib/mozilla-1.0.0/chrome/
> totalt 4644
> drwxr-xr-x    3 root     root         4096 jul  6 11:49 .
> drwxr-xr-x    9 root     root         4096 jun 27 11:31 ..
> -rw-r--r--    1 root     root       106693 jun  8 00:30 chatzilla.jar
> -rw-r--r--    1 root     root       196822 jun  8 00:30 chromelist.txt
> -rw-r--r--    1 root     root        38902 jul  6 11:49 chrome.rdf
> -rw-r--r--    1 root     root       291073 jun  8 00:30 classic.jar
> -rw-r--r--    1 root     root       887074 jun  8 00:30 comm.jar
> -rw-r--r--    1 root     root         3576 jun  8 00:30 content-packs.jar
> -r--------    1 root     root       603141 jul  6 00:05 da-DK.jar
> -r--------    1 root     root         3473 jul  6 00:05 da-mac.jar
> -r--------    1 root     root         4355 jul  6 00:05 da-unix.jar
> -r--------    1 root     root         6027 jul  6 00:05 da-win.jar
> -rw-r--r--    1 root     root         2758 jun  8 00:30 en-mac.jar
(...)


The problem is not in MozillaTranslator itself, but in Java's java.util.zip package:

http://mail-archives.apache.org/mod_mbox/ant-user/200104.mbox/%3cm3snjncu2e.fsf@bodewig.bost.de%3e

I'm willing to accept suggestions to solve this, but I don't see an easy solution.

Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

12 years ago
Reassigning every MT bug to me.
Assignee: henrik → rpmdisguise-otros
(Assignee)

Comment 5

12 years ago
The permissions problem is not actually related to the subject of this bug (using "_" instead of "-" for ab-CD.jar), which is solved, and since there is another bug dealing with permissions, I'm closing this one.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Mozilla Localizations → Mozilla Localizations Graveyard
You need to log in before you can comment on or make changes to this bug.