crash loading XML with XSL that uses xsl:key and the key function

VERIFIED FIXED

Status

()

Core
XSLT
--
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Antonio Fiol, Assigned: peterv)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020615
Debian/1.0.0-3
BuildID:    1.0.0 (Debian)

When loading the attached XML + XSL set, mozilla crashes.
There exist alternate ways of coding the XSL, but this one is AFAICT correct and
should work.
Anyway, if it is not correct, not working is accepted. Crashing is NOT.

Reproducible: Always
Steps to Reproduce:
1. Load the XML attachment.


Actual Results:  Crash

Expected Results:  "France" should appear, without the quotes.
(Reporter)

Comment 1

16 years ago
Created attachment 89404 [details]
Simple XML file. When loaded, Moz crashes.

Save both attachments in the same directory, and open this one.
(Reporter)

Comment 2

16 years ago
Created attachment 89405 [details]
A stylesheet using xsl:key and key()
(Reporter)

Comment 3

16 years ago
I think it is related to the following:

$ transfrmx -i test.xml              
TransforMiiX 1.0 [beta v20010123]
(C) 1999 The MITRE Corporation, Keith Visco, and contributors
--------------------------------------------------------------

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
    "http://www.w3.org/TR/REC-html40/loose.dtd">
<transformiix:result>function not yet implemented: key</transformiix:result>

This is what I get when trying to process the file in Transformiix

Comment 4

16 years ago
make sure this is not bug 141173. Branch foo, can't test myself.
Anyway, key is implemented for ages, I wonder what version of standalone that is.
(Reporter)

Comment 5

16 years ago
Sorry about the standalone. As you can see in my previous message (and I had not
seen), it is from last year. Probably way too old.

And re: the ressemblance to bug 141173, I cannot find any, but I do not know
anything about Mozilla internals, so maybe...
(Assignee)

Comment 6

16 years ago
Created attachment 89409 [details]
Simple XML file. When loaded, Moz crashes.
Attachment #89404 - Attachment is obsolete: true
(Assignee)

Comment 7

16 years ago
WFM.
Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0.0) Gecko/20020529
(Reporter)

Comment 8

16 years ago
Peter, I imagine that you changed "trial.xsl" by the URL of the other attachment.

I say I imagine, because when I tried to open your new attachment, my Mozilla
has blown away.

Comment 9

16 years ago
WFM. Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020626 on
Win2000.
(Assignee)

Comment 10

16 years ago
WFM with a trunk build from today too (on Mac).
(Reporter)

Comment 11

16 years ago
Seems Linux or Linux/Debian specific. Can anyone confirm?

Comment 12

16 years ago
Antonio, is your build talkback enabled? If so, please give some talkback IDs.
If not, could you download a talkback enabled build and generate one talkback
report?
Note that I triggered the crash in bug 141173 by running key() tests, and that it
is highly platform dependent.

Comment 13

16 years ago
wfm 20012062521/Debian (mozilla.org build)
works for me on a recent windows build
(Reporter)

Comment 15

16 years ago
Hello again:
WFM with a Debian package I built with the 1.1a sources and Debian debian/rules,
modifying every 1.0.0 by something else and deleting all the patches that did
not apply cleanly.

So, I mark this bug as FIXED, if you don't mind.

I'll post a bug on Debian Bug Tracking System asking to step up to 1.1a, if
possible.

Is there a way to specify on this bug that, even if it is fixed on 1.1a,
previous versions may show this bug?

BTW, thank you to all the people that were interested.

I will be investigating a strange behavior (new to 1.1a) concerning JavaScript
and XML/XSLT (rollover images not working).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
we didn't verify for a long time.
I really checked, so VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.