Closed Bug 1545943 Opened 2 years ago Closed 2 years ago

Permafailing toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | monitorConsole | number of messages [{message:/This extension is not allowed to run theme experiments/}] - got +0, expected 1 when Gecko 68 merges to Beta on 2019-05

Categories

(WebExtensions :: General, defect)

defect
Not set
normal

Tracking

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 affected)

RESOLVED DUPLICATE of bug 1543696
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- affected

People

(Reporter: nataliaCs, Unassigned)

Details

[Tracking Requested - why for this release]:
Central as Beta:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a11dcc7ee26305cc0b02dc443b03fd2a8372baab&group_state=expanded&searchStr=browser-chrome&selectedJob=241613063

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=241613063&repo=try&lineNumber=4988

[task 2019-04-20T14:12:04.516Z] 14:12:04 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | monitorConsole | number of messages [{message:/Unrecognized theme property found: properties.such_property/}] -
[task 2019-04-20T14:12:04.520Z] 14:12:04 INFO - Leaving test bound test_dynamic_theme
[task 2019-04-20T14:12:04.521Z] 14:12:04 INFO - Entering test bound test_experiment
[task 2019-04-20T14:12:04.522Z] 14:12:04 INFO - Testing that experiments are handled correctly when legacy pref is enabled
[task 2019-04-20T14:12:04.523Z] 14:12:04 INFO - Extension loaded
[task 2019-04-20T14:12:04.525Z] 14:12:04 INFO - Console message: Warning: attempting to write 7399 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-04-20T14:12:04.526Z] 14:12:04 INFO - Console message: 1555769523508 addons.webextension.{02207e79-7cbc-4a99-b25d-da755e25bdda} WARN Unrecognized theme property found: properties.unknown_property
[task 2019-04-20T14:12:04.527Z] 14:12:04 INFO - Console message: SENTINEL
[task 2019-04-20T14:12:04.528Z] 14:12:04 INFO - Buffered messages finished
[task 2019-04-20T14:12:04.533Z] 14:12:04 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | monitorConsole | number of messages [{message:/This extension is not allowed to run theme experiments/}] - got +0, expected 1
[task 2019-04-20T14:12:04.534Z] 14:12:04 INFO - Stack trace:
[task 2019-04-20T14:12:04.535Z] 14:12:04 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.is:320
[task 2019-04-20T14:12:04.536Z] 14:12:04 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:listener:1323
[task 2019-04-20T14:12:04.537Z] 14:12:04 INFO - chrome://mochikit/content/tests/SimpleTest/specialpowersAPI.js:observe/<:377
[task 2019-04-20T14:12:04.538Z] 14:12:04 INFO - Testing that experiments are handled correctly when legacy pref is disabled
[task 2019-04-20T14:12:04.544Z] 14:12:04 INFO - Extension loaded
[task 2019-04-20T14:12:04.545Z] 14:12:04 INFO - Console message: Warning: attempting to write 7479 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-04-20T14:12:04.546Z] 14:12:04 INFO - GECKO(4763) | monitorConsole | [0] did not match {"message":"Warning: attempting to write 7479 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.","errorMessage":null,"cssSelectors":null,"sourceName":null,"sourceLine":null,"lineNumber":null,"columnNumber":null,"category":null,"windowID":null,"isScriptError":false,"isConsoleEvent":false,"isWarning":false,"isException":false,"isStrict":false}
[task 2019-04-20T14:12:04.553Z] 14:12:04 INFO - GECKO(4763) | 1555769523867 addons.webextension.{71d1af3b-cc88-493e-85cb-fa42195c1a16} WARN This extension is not allowed to run theme experiments
[task 2019-04-20T14:12:04.554Z] 14:12:04 INFO - Console message: 1555769523867 addons.webextension.{71d1af3b-cc88-493e-85cb-fa42195c1a16} WARN This extension is not allowed to run theme experiments
[task 2019-04-20T14:12:04.555Z] 14:12:04 INFO - Console message: SENTINEL
[task 2019-04-20T14:12:04.556Z] 14:12:04 INFO - GECKO(4763) | monitorConsole | [0] matched {"message":"1555769523867\taddons.webextension.{71d1af3b-cc88-493e-85cb-fa42195c1a16}\tWARN\tThis extension is not allowed to run theme experiments","errorMessage":null,"cssSelectors":null,"sourceName":null,"sourceLine":null,"lineNumber":null,"columnNumber":null,"category":null,"windowID":null,"isScriptError":false,"isConsoleEvent":false,"isWarning":false,"isException":false,"isStrict":false}
[task 2019-04-20T14:12:04.557Z] 14:12:04 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | monitorConsole | number of messages [{message:/This extension is not allowed to run theme experiments/}] -

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1543696
You need to log in before you can comment on or make changes to this bug.