Closed Bug 1545969 Opened 1 year ago Closed 1 year ago

Non-native scrollbars in dark mode

Categories

(Firefox :: Theme, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- disabled
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 - disabled
firefox69 --- disabled
firefox70 --- fixed

People

(Reporter: yoasif, Assigned: ntim)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(4 files)

Noticed that when using dark mode, Firefox no longer uses native GTK scrollbars.

STR:

  1. Use dark mode theme in OS
  2. Ensure browser.in-content.dark-mode is enabled
  3. Navigate to any of:

about:support
about:profiles
about:preferences
about:crashes
there are others, but you get the idea.

What happens:

I see rectangular scrollbars that don't match the rest of my system.

Expected result:

The old scrollbars, or the ones in 1147847

Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → Linux
Regressed by: 1544025
See Also: → 1147847
Attached image good-adwaita.png
Attached image good-yaru.png
Flags: needinfo?(richard.marti)

I think this is more a GTK issue as on Mac it still looks native with the rounded scrollbar thumb. GTK should follow this too

Flags: needinfo?(richard.marti)

This regresses the nice scrollbars I see when browsing web content and what used to appear previously. While it'd be nice to get improvements in the GTK scrollbars, (see Bug 1147847), it doesn't really help this regression unless new scrollbars land in GTK for Firefox 68.

Priority: -- → P3

Dao, are we intending to ship with this regression or should we back out the regressing bug until this can be addressed?

Flags: needinfo?(dao+bmo)

This feature is currently pref'd off so there's effectively no regression (yet).

Flags: needinfo?(dao+bmo)
Blocks: 1565051

This is probably due to using scrollbar-color:
https://searchfox.org/mozilla-central/source/toolkit/themes/shared/in-content/common.inc.css#146

Both Windows and macOS have the ability to apply colors to their standard scrollbar widgets, but GTK doesn't. So Firefox's implementation of the CSS scrollbar-color property falls back to a generic style for scrollbars respecting the desired colors, and bypasses the GTK scrollbars altogether.

We had a bunch of discussions on that topic for devtools in bug 1504787.

Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/93ef77eda2f0
Don't apply scrollbar-color on Linux in common.css. r=dao
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

You need to log in before you can comment on or make changes to this bug.