Perma browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js | Test timed out -

RESOLVED FIXED in Firefox 67

Status

()

defect
P5
normal
RESOLVED FIXED
3 months ago
6 days ago

People

(Reporter: intermittent-bug-filer, Assigned: standard8)

Tracking

({regression})

unspecified
Firefox 67
Points:
1

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 fixed, firefox68 unaffected)

Details

Attachments

(1 attachment)

#[markdown(off)]
Filed by: nbeleuzu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=241655565&repo=mozilla-beta

https://queue.taskcluster.net/v1/task/I-DS3qjzTpCfZgxK5hDqHA/runs/0/artifacts/public/logs/live_backing.log

[task 2019-04-21T02:24:59.749Z] 02:24:59 INFO - TEST-START | browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js
[task 2019-04-21T02:25:44.763Z] 02:25:44 INFO - TEST-INFO | started process screentopng
[task 2019-04-21T02:25:45.231Z] 02:25:45 INFO - TEST-INFO | screentopng: exit 0
[task 2019-04-21T02:25:45.232Z] 02:25:45 INFO - Buffered messages logged at 02:24:59
[task 2019-04-21T02:25:45.233Z] 02:25:45 INFO - Entering test bound
[task 2019-04-21T02:25:45.233Z] 02:25:45 INFO - Buffered messages finished
[task 2019-04-21T02:25:45.234Z] 02:25:45 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js | Test timed out -
[task 2019-04-21T02:25:45.235Z] 02:25:45 INFO - GECKO(8209) | MEMORY STAT | vsize 2048MB | residentFast 374MB | heapAllocated 121MB
[task 2019-04-21T02:25:45.236Z] 02:25:45 INFO - TEST-OK | browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js | took 45028ms

Summary: Intermittent browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js | Test timed out - → Perma browser/components/urlbar/tests/browser/browser_UrlbarInput_tooltip.js | Test timed out -

I'll do a beta build and see if it's related.

Well, I cannot get a beta build to complete on linux, neither artifact or full. This could take longer, need to figure out why rust hates me.

Looking at the test, I cannot see how my changes would affect this, it seems more plausible that there is some kind of focus issue going on. However, a simple test may be to run the tests with the patch backed out.

Flags: needinfo?(mixedpuppy)

On my beta build I'm unable to make this test fail.

Sigh, that's devedition only again.

We've had problems with this test in the past (xref bug 1504191, bug 1504985, bug 1511655, bug 1511856, bug 1536508).

Narcis, could you try Shane's suggestion of running a build without the patch? I can't see anything obvious for why that patch would have affected it.

Flags: needinfo?(nbeleuzu)

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #7)

The permafail is not new, it's failing for 3 weeks and only switched chunks: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&resultStatus=success%2Ctestfailed%2Cbusted%2Cexception%2Crunnable&searchStr=linux%2Cx64%2Cdevedition%2Cbrowser-chrome&tochange=13d26dc811fe304c8c38bb4b6da79020467164b1&fromchange=a6c41b0eebc2d225fe633bc95554c10d233fcc02&group_state=expanded&selectedJob=237222547

Err, that range doesn't seem quite right. In any case, I just realised we're talking about beta and not beta-as-simulation. I guess we should try uplifting one or more of the bugs that we've already fixed for the beta simulations.

I'll see if I can figure out which patches to apply tomorrow.

Assignee: nobody → standard8

So uplifing bug 1536508 failed on try - the test still times out.

Since this is QuantumBar, beta-only (67), and we're not enabling it there, lets just go for disabling it.

Points: --- → 1
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Iteration: --- → 68.3 - Apr 15 - 28
You need to log in before you can comment on or make changes to this bug.