"Recent Closed Tabs" and "Recent Closed Windows" list in Menubar does not show

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
29 days ago
23 days ago

People

(Reporter: alice0775, Assigned: bgrins)

Tracking

(Regression, {nightly-community, regression})

68 Branch
Firefox 68
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

29 days ago

Reproducible: always

Steps To Reproduce:

  1. Close tabs
  2. Press Alt key > History > Recent Closed Tabs

And

  1. Open web page in New window(Ctrl+N)
  2. Close the window
  3. Press Alt key > History > Recent Closed Windows

Actual Results:
Nothing is displayed

Expected Results:
Closed tabs list should show
Closed windows list should show

Regression Window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=27157cc6395ef681545b5a8ae5f95fc584f38792&tochange=223a8a0c4eed19547e6e843cfd265c728f7dc7c2

Suspect:
223a8a0c4eed Brian Grinstead — Bug 1519502 - Convert menu bindings to a Custom Element r=surkov

(Reporter)

Comment 1

29 days ago

:bgrins, Your bunch of patch seems to cause the regression. Can you please look into this?

Flags: needinfo?(bgrinstead)
(Assignee)

Comment 2

28 days ago

Thanks for filing. This looks like an easy fix (firstChild -> menupopup): https://searchfox.org/mozilla-central/rev/52b651e168a5b3a923bed0ef977a3fd27c5dd713/browser/base/content/browser-places.js#605. More concerning is the fact no tests failed here - I'll have a look.

Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)

Comment 4

28 days ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/61587f94c172
Update "Recent Closed Tabs" and "Recent Closed Windows" menus to reference their menupopup correctly r=Gijs
(Assignee)

Updated

28 days ago
See Also: → 1546099

Updated

28 days ago
Priority: -- → P1

Comment 5

27 days ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 68.0a1 (2019-04-23), so I'm marking this bug as VERIFIED.
Thank you very much! \o/

Status: RESOLVED → VERIFIED
QA Contact: Virtual
You need to log in before you can comment on or make changes to this bug.