"SEC_ERROR_EXPIRED_CERTIFICATE" not readable in dark mode

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
18 days ago

People

(Reporter: alberts, Assigned: ntim)

Tracking

(Blocks 1 bug)

68 Branch
Firefox 68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 verified, firefox69 verified)

Details

Attachments

(3 attachments)

Parts of the error message in the info box are not readable in dark theme (or default theme + OS dark mode), please see screenshot:

Component: Untriaged → Theme
Assignee: nobody → ntim.bugs
Priority: -- → P1
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a5b40abdd065
Fix contrast of advanced panel in about:neterror in dark mode. r=johannh
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Flags: qe-verify+

I reproduced the issue on Firefox Nightly 68.0a1 (2019-04-21) under Windows 10 (x64) by using the details from the png file in Comment 0.

The issue is not reproducible anymore on latest Nightly 69.0a1 (2019-07-02), but on Firefox DevEdition 69.0b1-build2 I get the same page but it's using white theme in spite dark theme is selected.

On 68.0b14 and RC1 68 I get a different page stating that "Your computer clock is wrong" (I'll attach a screenshot) and in this case too, it seems that it doesn't take count about the dark theme being selected.

Tim, can you take a look over this? Is the page with the initial warning as in Comment 0 supposed to appear only on Nightly? Thanks!

Flags: needinfo?(ntim.bugs)

(In reply to Catalin Sasca, QA [:csasca] from comment #4)

Created attachment 9075591 [details]
2019-05-01 11_38_23-Window.png

I reproduced the issue on Firefox Nightly 68.0a1 (2019-04-21) under Windows 10 (x64) by using the details from the png file in Comment 0.

Thanks for verifying !

On 68.0b14 and RC1 68 I get a different page stating that "Your computer clock is wrong" (I'll attach a screenshot) and in this case too, it seems that it doesn't take count about the dark theme being selected.

Dark mode integration is only enabled in Nightly at the moment, although you can enable it by turning on the browser.in-content.dark-mode preference.

Flags: needinfo?(ntim.bugs)

So I verified on 68.0 too and the issue is no longer reproducible. Tests were performed on macOS 10.14 where dark mode is native from OS, Ubuntu 18.04 with some tweaks and Windows 10.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.