Remove support for XBL <resources>

RESOLVED FIXED in Firefox 68

Status

()

task
P2
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

(Blocks 1 bug, Regressed 1 bug)

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

No description provided.

Now that we can remove the last usage in-tree of <xbl:resources> in bug 1470880, we can remove the implementation, yay!

Jordi, fyi. I think this shouldn't affect Thunderbird:

https://searchfox.org/comm-central/search?q=%3Cresources%3E&case=false&regexp=false&path=

There's a bunch of usage under suite/, but that's about it.

Blocks: war-on-xbl
Type: defect → task
Depends on: 1470880
Flags: needinfo?(jorgk)

Thanks for the heads-up. Yes, we have removed <resources> bit by bit, but there is one left in common/ which would break us.

Flags: needinfo?(richard.marti)
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(jorgk)

I think that remaining one is not necessary since button.css is included in widgets.css - https://searchfox.org/comm-central/source/mozilla/toolkit/content/widgets.css#11

We can't convert the menu-button binding yet since button hasn't yet been de-xbl'd in mozilla-central yet.

Is this a dupe of bug 1474069?

Flags: needinfo?(mkmelin+mozilla)

I'm on removing the last <resource> in common. It needs some tweaks to look like before.

Flags: needinfo?(richard.marti)

I filed bug 1546082 for the remaining <resources> for TB.

Depends on: 1546082

So much unsound code going away :-)

Duplicate of this bug: 1474069
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e85cb54e5944
Remove support for XBL resources. r=TYLin
Depends on: 1474070

Backed out changeset e85cb54e5944 (Bug 1546046) complementary backout after 1470880 was backed out

Bug 1546256 was caused by not backing this out alongside 1470880.

Regressions: 1546256
Priority: -- → P2
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1855d66f55a5
Remove support for XBL resources. r=TYLin
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.