Long delays when clicking in preference panel

VERIFIED DUPLICATE of bug 15596

Status

defect
P3
critical
VERIFIED DUPLICATE of bug 15596
20 years ago
15 years ago

People

(Reporter: morse, Assigned: danm.moz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
I think all dialogs are suddenly displaying this problem. But since I have an
example that displays it for the preference panel, I'm assigning it agains
pref-UI.  But it's probably more general than that.

Here's the example.  Open the edit/preference window.  Go to advanced pane.
Check the "warn-me-before-accepting-cookies box.  No checkmark appears.  Keep
clicking on it for a long time and finally the checkmark appears.  (Maybe the
repeated clicks had nothing to do with this and it would have appeared after the
long delay all by itself.)

Then hit the OK button.  Nothing happens.  Keep hitting the OK button many many
times and after a very long time the dialog finally dismisses.  I looked at the
generated prefs.js file and at least the right thing got put into that file.

Comment 1

20 years ago
When I saw this occur, it seemed to be that only a certain place on the
"OK" button would take the mouse clicks

Comment 2

20 years ago
*** Bug 15455 has been marked as a duplicate of this bug. ***

Comment 3

20 years ago
Perhaps this should read 'must double-click when clicking in dialogs', since
that seems to be the problem.
Reporter

Comment 4

20 years ago
Sometimes that's the problem.  But at other times even double-clicking doesn't
help.  I haven't yet been able to determine when double-clicking helps and when
it doesn't.  It seems to me that double-clicking wasn't working in the
preferences when I first noticed this but that it is now (and I haven't changed
any code in my tree).

Updated

20 years ago
Severity: normal → critical
Target Milestone: M10

Comment 5

20 years ago
Setting to M10 since found on this branch and we need to know what's goind on
here.  At least for Release Notes if we do have a defined workaround.
Reporter

Comment 6

20 years ago
Adding davidm and danm to cc list since this is obviously more general than just
preference panels and may actually be in one of their areas.

Comment 7

20 years ago
wondering if danm fix for bug 15596 to the m10 branch will help this?
should appear in the next respin for retest
Assignee

Updated

20 years ago
Assignee: matt → danm
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
Assignee

Comment 8

20 years ago
Oh yeah: same problem as 15596.  I don't currently have an M10 build, but when I tested
my fix for 15596 on the M10 branch, symptoms described in this bug, which were there before
the fix, went away.  Calling it a duplicate.


*** This bug has been marked as a duplicate of 15596 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 9

20 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.