about-telemetry-settings-explanation is passed the wrong argument parameters, breaking telemetry channel ("release" vs "pre-release" data) information in about:telemetry

RESOLVED FIXED in Firefox 68

Status

()

defect
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: Gijs, Assigned: nautilus)

Tracking

(Regression)

Trunk
mozilla68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 months ago

The console indicates:

console.warn: "[fluent][resolver] errors in en-US/about-telemetry-settings-explanation: ReferenceError: Unknown variable: channel."

This is because

https://searchfox.org/mozilla-central/rev/d80f0a570736dce76a2eb184fb65517462089e8a/toolkit/locales/en-US/toolkit/about/aboutTelemetry.ftl#72

about-telemetry-settings-explanation = Telemetry is collecting { about-telemetry-data-type } and upload is <a data-l10n-name="upload-link">{ about-telemetry-upload-type }</a>.

includes about-telemetry-data-type, and that looks like this:

https://searchfox.org/mozilla-central/rev/d80f0a570736dce76a2eb184fb65517462089e8a/toolkit/locales/en-US/toolkit/about/aboutTelemetry.ftl#43-50

# Selects the correct release version
# Variables:
#   $channel (String): represents the corresponding release data string
about-telemetry-data-type =
    { $channel ->
        [release] release data
       *[prerelease] pre-release data
    }

so it expects a "channel" property on the l10n-args object we pass, but https://searchfox.org/mozilla-central/rev/d80f0a570736dce76a2eb184fb65517462089e8a/toolkit/content/aboutTelemetry.js#212 passes a datacase and uploadcase instead. Looks like datacase should be channel in the JS.

Avery, can you or one of your colleagues pick this up?

Flags: needinfo?(berning5)
Assignee: nobody → nickcowles9575
Status: NEW → ASSIGNED
Flags: needinfo?(berning5)

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Reporter

Comment 2

2 months ago

This is a user-visible thing once 68 goes to beta/release (because the string is set up to default to pre-release which happens to be OK on nightly).

Type: task → defect
Summary: about-telemetry-settings-explanation is passed the wrong argument parameters → about-telemetry-settings-explanation is passed the wrong argument parameters, breaking telemetry channel ("release" vs "pre-release" data) information in about:telemetry
Assignee: nickcowles9575 → freychr3

Comment 4

2 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f9ccfa09fb6d
Fixing argument paramater passed to about-telemetry-settings-explanation to fix release vs pre-release info in about:telemetry r=Gijs

Comment 5

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.