Crash in [@ void mozilla::MediaManager::IterateWindowListeners<T>(nsPIDOMWindowInner*, mozilla::MediaManager::OnDeviceChange()::$_33::operator()() const::'lambda'(bool)::operator()(bool) const::'lambda'(RefPtr<T> const&) const&)]

RESOLVED DUPLICATE of bug 1540434

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1540434
a month ago
a month ago

People

(Reporter: gsvelto, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Reporter

Description

a month ago

This bug is for crash report bp-e0a61b7f-e170-4805-851a-d2c060190419.

Top 10 frames of crashing thread:

0 XUL void mozilla::MediaManager::IterateWindowListeners<mozilla::MediaManager::OnDeviceChange mfbt/UniquePtr.h:308
1 XUL mozilla::MozPromise<bool, RefPtr<mozilla::MediaMgrError>, true>::ThenValue<mozilla::MediaManager::OnDeviceChange xpcom/threads/MozPromise.h:717
2 XUL mozilla::MozPromise<bool, RefPtr<mozilla::MediaMgrError>, true>::ThenValueBase::ResolveOrRejectRunnable::Run xpcom/threads/MozPromise.h:393
3 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
4 XUL nsThread::Shutdown xpcom/threads/nsThread.cpp:881
5 XUL mozilla::MediaStreamGraphShutdownThreadRunnable::Run dom/media/GraphDriver.cpp:158
6 XUL mozilla::SchedulerGroup::Runnable::Run xpcom/threads/SchedulerGroup.cpp:295
7 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
8 XUL nsThread::Shutdown xpcom/threads/nsThread.cpp:881
9 XUL mozilla::MediaStreamGraphShutdownThreadRunnable::Run dom/media/GraphDriver.cpp:158

I found two signatures for this crash with very similar stacks but different crash reasons.

Reporter

Comment 1

a month ago

I found another signature (Windows/Linux) with a very similar stack; my guess is that it's the same issue.

Crash Signature: [@ void mozilla::MediaManager::IterateWindowListeners<T>(nsPIDOMWindowInner*, mozilla::MediaManager::OnDeviceChange()::$_33::operator()() const::'lambda'(bool)::operator()(bool) const::'lambda'(RefPtr<T> const&) const&)] [@ InvalidArrayIndex_CRASH | void… → [@ InvalidArrayIndex_CRASH | mozilla::GetUserMediaWindowListener::StopRawID] [@ InvalidArrayIndex_CRASH | void mozilla::MediaManager::IterateWindowListeners<T>(nsPIDOMWindowInner*, mozilla::MediaManager::OnDeviceChange()::$_33::operator()() const::'lambd…
OS: macOS → All
Reporter

Comment 2

a month ago

It seems that this is just a dupe of bug 1540434 with a different signature, closing.

Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1540434
You need to log in before you can comment on or make changes to this bug.