page loaded from cache messed up if switch character coding after page cached

VERIFIED WORKSFORME

Status

()

Core
Internationalization
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Matevz Jekovec, Assigned: Roy Yokoyama)

Tracking

({intl})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530
BuildID:    20020530

Text is ok for a while and the it messes up. Also, if you follow links, the
beginnings of the texts are ok and then they mess up, so looks like a global
problem of the whole website.
Works fine in IE.

Comment 1

16 years ago
WFM on Linux 2002062608.

Reporter, could you please attach a screenshot showing the problem you are seeing?


(Reporter)

Comment 2

16 years ago
Created attachment 89432 [details]
Screenshot1

I believe I found a problem. I have a default language set to Central European
(8859-2). If I load the page in this language, page messes up. BUT, when I
change language from CE to Western (8859-1) fontset, everything works OK
(except some Slovenian characters of course). And when I set fonts back to
8859-2, it worked just fine then. I believe, the page itself stays in cache, so
when I switched the language, only the cached variant of the page was being
processed. Obviously, for the first time when you load the page, there is
something that it can't be processed in CE fontset or what?
->i18n
Assignee: attinasi → yokoyama
Component: Layout → Internationalization
QA Contact: petersen → ruixu

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 4

16 years ago
Reporter:
Could you please provide a detail reproduce steps if there is any? cause it
works for me when I set the default font to Central European or charset to
iso-8859-2.  Thanks!

Updated

16 years ago
Summary: Page messed up → page loaded from cache messed up if switch character coding after page cached
(Reporter)

Comment 5

16 years ago
Wow, today I revisited the page in CE by default and everything worked for the
first time. Even some pages I haven't visited yet work fine (cache)... I'm not
pretty sure what happened. Maybe administrator changed the content...
worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
Great! Thanks.  I'll mark as works for me then.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.