Open Bug 1546256 Opened 4 months ago Updated 19 days ago

Intermittent toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out.

Categories

(Toolkit :: XUL Widgets, defect, P5)

defect

Tracking

()

REOPENED
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fix-optional

People

(Reporter: intermittent-bug-filer, Assigned: emilio)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disabled])

Attachments

(2 files)

#[markdown(off)]
Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=241936265&repo=autoland

https://queue.taskcluster.net/v1/task/XqhigbEEQ4CAS5WZ1YLP0A/runs/0/artifacts/public/logs/live_backing.log

01:13:20 INFO - TEST-START | toolkit/content/tests/chrome/test_arrowpanel.xul
01:13:20 INFO - GECKO(1073) | ++DOMWINDOW == 38 (0x1349d2c00) [pid = 1073] [serial = 38] [outer = 0x1347b67a0]
01:13:20 INFO - GECKO(1073) | ++DOCSHELL 0x133fd6800 == 13 [pid = 1073] [id = {a0410023-dce2-744b-a5a0-bb546e3743ea}]
01:13:20 INFO - GECKO(1073) | ++DOMWINDOW == 39 (0x134822f20) [pid = 1073] [serial = 39] [outer = 0x0]
01:13:20 INFO - GECKO(1073) | [1073, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 3771
01:13:20 INFO - GECKO(1073) | ++DOMWINDOW == 40 (0x1349dc800) [pid = 1073] [serial = 40] [outer = 0x134822f20]
01:13:22 INFO - GECKO(1073) | [1073, Main Thread] WARNING: NS_ENSURE_TRUE(weakFrame.IsAlive()) failed: file /builds/worker/workspace/build/src/layout/xul/nsXULPopupManager.cpp, line 1061
01:13:24 INFO - GECKO(1073) | --DOCSHELL 0x12d192800 == 12 [pid = 1073] [id = {93e7b1b4-3df5-8946-9788-d44eea0c3464}] [url = moz-extension://4842a47b-df7d-5a4a-85a5-751f5ab853be/_generated_background_page.html]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 39 (0x1341d3000) [pid = 1073] [serial = 35] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 38 (0x1341d1c00) [pid = 1073] [serial = 34] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 37 (0x12bb18000) [pid = 1073] [serial = 18] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 36 (0x12ecabc00) [pid = 1073] [serial = 26] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 35 (0x13302f800) [pid = 1073] [serial = 29] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 34 (0x12bb17400) [pid = 1073] [serial = 17] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 33 (0x12bb16c00) [pid = 1073] [serial = 16] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 32 (0x12bb15c00) [pid = 1073] [serial = 15] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 31 (0x12bb12c00) [pid = 1073] [serial = 14] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 30 (0x12d1d1400) [pid = 1073] [serial = 7] [outer = 0x0] [url = about:blank]
01:13:31 INFO - GECKO(1073) | --DOMWINDOW == 29 (0x12d42cc40) [pid = 1073] [serial = 13] [outer = 0x0] [url = moz-extension://4842a47b-df7d-5a4a-85a5-751f5ab853be/_generated_background_page.html]
01:13:32 INFO - GECKO(1073) | --DOMWINDOW == 28 (0x12d3a0800) [pid = 1073] [serial = 23] [outer = 0x0] [url = moz-extension://4842a47b-df7d-5a4a-85a5-751f5ab853be/_generated_background_page.html]
01:13:32 INFO - GECKO(1073) | --DOMWINDOW == 27 (0x1341dd000) [pid = 1073] [serial = 36] [outer = 0x0] [url = chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_about_networking.html]
01:13:32 INFO - GECKO(1073) | --DOMWINDOW == 26 (0x12f0d4000) [pid = 1073] [serial = 27] [outer = 0x0] [url = about:blank]
01:13:32 INFO - GECKO(1073) | --DOMWINDOW == 25 (0x1349d6000) [pid = 1073] [serial = 37] [outer = 0x0] [url = chrome://mochikit/content/tests/SimpleTest/iframe-between-tests.html]
01:13:35 INFO - GECKO(1073) | [1073, StreamTrans #5] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/modules/libjar/nsJARChannel.cpp, line 371
01:13:35 INFO - GECKO(1073) | [1073, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file /builds/worker/workspace/build/src/modules/libjar/nsJARChannel.cpp, line 994
01:13:38 INFO - GECKO(1073) | 2019-04-23 01:13:38.923 firefox[1073:12414] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightlydebug.savedState/window_1.data: No such file or directory (2)
01:18:49 INFO - TEST-INFO | started process screencapture
01:18:49 INFO - TEST-INFO | screencapture: exit 0
01:18:49 INFO - <snipped 334 output lines - if you need more context, please use SimpleTest.requestCompleteLog() in your test>
01:18:49 INFO - Buffered messages logged at 01:13:23
01:18:49 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | panel arrow side
...
01:18:49 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | big panel height
01:18:49 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | state is showing
01:18:49 INFO - Buffered messages finished
01:18:49 INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out.
01:18:49 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:275:18
01:18:49 INFO - reportError@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:121:22
01:18:49 INFO - TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:142:7
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - setTimeout handler*TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:18:49 INFO - TestRunner.runTests/<@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:381:20
01:18:49 INFO - promise callback*TestRunner.runTests@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:368:50
01:18:49 INFO - RunSet.runtests@chrome://mochikit/content/tests/SimpleTest/setup.js:201:14
01:18:49 INFO - RunSet.runall@chrome://mochikit/content/tests/SimpleTest/setup.js:180:12
01:18:49 INFO - hookupTests@chrome://mochikit/content/tests/SimpleTest/setup.js:273:12
01:18:49 INFO - parseTestManifest@chrome://mochikit/content/manifestLibrary.js:38:5
01:18:49 INFO - getTestManifest/req.onload@chrome://mochikit/content/manifestLibrary.js:49:11
01:18:49 INFO - EventHandlerNonNull*getTestManifest@chrome://mochikit/content/manifestLibrary.js:45:3
01:18:49 INFO - hookup@chrome://mochikit/content/tests/SimpleTest/setup.js:253:5
01:18:49 INFO - linkAndHookup@chrome://mochikit/content/harness.xul:45:3
01:18:49 INFO - parseTestManifest@chrome://mochikit/content/manifestLibrary.js:38:5
01:18:49 INFO - getTestManifest/req.onload@chrome://mochikit/content/manifestLibrary.js:49:11
01:18:49 INFO - EventHandlerNonNull*getTestManifest@chrome://mochikit/content/manifestLibrary.js:45:3
01:18:49 INFO - getTestList@chrome://mochikit/content/chrome-harness.js:251:3
01:18:49 INFO - loadTests@chrome://mochikit/content/harness.xul:24:3

Summary: Intermittent toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out. → Perma fail toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out.
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(emilio)
Flags: needinfo?(bgrinstead)
Assignee: nobody → emilio
Regressed by: 1546046
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

hey emilio, looks like bug 1546046 relanded and re-broke this. Do you plan to fix this in 68? Thanks!

Flags: needinfo?(emilio)

Is it really a perma-fail? I'm pretty sure if it was my patch would've been backed out again. I should've fixed it with an updated patch in bug 1470880.

Flags: needinfo?(emilio) → needinfo?(plawless)
Assignee: emilio → nobody

(I'm not actively working on this, because I'm pretty sure it's not a perma-fail. If it fails intermittently and the intermittent rate is high I'm happy to dig into it.)

Looking at orange-factor, looks like this has failed in win32-debug a couple times, and in mac64-debug one time. I'm unsure about whether my patch ends up to being to blame for that, but if it is it's really a pre-existing bug. This bug initially happened because bug 1470880 was backed out without bug 1546046 being backed out (the latter depended on the former).

Summary: Perma fail toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out. → Intermittent toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out.

There are 30 total failures in the last 7 days: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-05-07&endday=2019-05-14&tree=trunk&bug=1546256

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=246263437&repo=autoland&lineNumber=16140

01:47:22 INFO - TEST-START | toolkit/content/tests/chrome/test_arrowpanel.xul
01:52:51 INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out.
01:52:51 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:275:18
01:52:51 INFO - reportError@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:121:22
01:52:51 INFO - TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:142:7
01:52:51 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
01:52:51 INFO - TestRunner.runTests/<@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:381:20
01:52:51 INFO - promise callback
TestRunner.runTests@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:368:50
01:52:51 INFO - RunSet.runtests@chrome://mochikit/content/tests/SimpleTest/setup.js:201:14
01:52:51 INFO - RunSet.runall@chrome://mochikit/content/tests/SimpleTest/setup.js:180:12
01:52:51 INFO - hookupTests@chrome://mochikit/content/tests/SimpleTest/setup.js:273:12
01:52:51 INFO - parseTestManifest@chrome://mochikit/content/manifestLibrary.js:38:5
01:52:51 INFO - getTestManifest/req.onload@chrome://mochikit/content/manifestLibrary.js:49:11
01:52:51 INFO - EventHandlerNonNullgetTestManifest@chrome://mochikit/content/manifestLibrary.js:45:3
01:52:51 INFO - hookup@chrome://mochikit/content/tests/SimpleTest/setup.js:253:5
01:52:51 INFO - linkAndHookup@chrome://mochikit/content/harness.xul:45:3
01:52:51 INFO - parseTestManifest@chrome://mochikit/content/manifestLibrary.js:38:5
01:52:51 INFO - getTestManifest/req.onload@chrome://mochikit/content/manifestLibrary.js:49:11
01:52:51 INFO - EventHandlerNonNull
getTestManifest@chrome://mochikit/content/manifestLibrary.js:45:3
01:52:51 INFO - getTestList@chrome://mochikit/content/chrome-harness.js:251:3
01:52:51 INFO - loadTests@chrome://mochikit/content/harness.xul:24:3
01:52:51 INFO - EventListener.handleEvent*@chrome://mochikit/content/harness.xul:48:12
01:52:52 INFO - GECKO(1552) | MEMORY STAT | vsize 817MB | vsizeMaxContiguous 612MB | residentFast 253MB | heapAllocated 74MB
01:52:52 INFO - TEST-OK | toolkit/content/tests/chrome/test_arrowpanel.xul | took 329877ms
01:52:52 INFO - GECKO(1552) | ++DOMWINDOW == 29 (0E8C6000) [pid = 4244] [serial = 50] [outer = 1C67DA60]

Whiteboard: [stockwell needswork:owner]

Sorry for the slow response here. I was mostly checking in for release purposes (whether this will be fixed for 68 :)

Flags: needinfo?(plawless)

Over the last 7 days this bug has 38 failures. These happen on windows7-32

Here is the most recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=248304977&repo=autoland&lineNumber=16607

Flags: needinfo?(enndeakin)

It looks like the original failure here was caused by bug 1546046 and fixed by 1470880. More recent failures though are different. You might notice that the logs of the newer failures are only on Windows and the logs are different.

A failing log:

23:13:51 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | big panel height
23:13:51 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | state is showing
23:13:51 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | state is showing during transitionend
23:13:51 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | popupshown not fired yet
23:13:51 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | state is showing during transitionend
23:13:51 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | popupshown not fired yet

(The earlier failure fails four lines earlier after 'state is showing')

For reference, a passing log:

0:30.16 PASS state is showing
0:30.37 PASS state is showing during transitionend
0:30.37 PASS popupshown not fired yet
0:30.37 PASS state is open after transitionend
0:30.37 PASS popupshown now fired

The new failures started around April 29.

It looks like the transitionend event fired twice while popup is not is the open state and then stops in the fail cases. When I run the test manually, I don't get the duplicated lines.

Given that, I might have suspected bug 1546542 based on this, and that bug it has a dependent Windows-only performance regression. But that bug was a few days earlier on April 24.

Would be worth looking into to find out what else might have changed around then.

Flags: needinfo?(enndeakin)

In the last 7 days, there have been 54 failures.

The failures are on windows7-32 platform, debug build type.

An example of a recent log file:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=249602089&repo=mozilla-inbound&lineNumber=17121

And the relevant part of the log:
11:17:38 INFO - TEST-PASS | toolkit/content/tests/chrome/test_arrowpanel.xul | popupshown not fired yet
11:17:38 INFO - Buffered messages finished
11:17:38 INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out.
11:17:38 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:275:18
11:17:38 INFO - reportError@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:121:22
11:17:38 INFO - TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:142:7
11:17:38 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
11:17:38 INFO - TestRunner.runTests/<@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:381:20
11:17:38 INFO - promise callback
TestRunner.runTests@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:368:50
11:17:38 INFO - RunSet.runtests@chrome://mochikit/content/tests/SimpleTest/setup.js:201:14
11:17:38 INFO - RunSet.runall@chrome://mochikit/content/tests/SimpleTest/setup.js:180:12
11:17:38 INFO - hookupTests@chrome://mochikit/content/tests/SimpleTest/setup.js:273:12
11:17:38 INFO - parseTestManifest@chrome://mochikit/content/manifestLibrary.js:38:5
11:17:38 INFO - getTestManifest/req.onload@chrome://mochikit/content/manifestLibrary.js:49:11
11:17:38 INFO - EventHandlerNonNullgetTestManifest@chrome://mochikit/content/manifestLibrary.js:45:3
11:17:38 INFO - hookup@chrome://mochikit/content/tests/SimpleTest/setup.js:253:5
11:17:38 INFO - linkAndHookup@chrome://mochikit/content/harness.xul:45:3
11:17:38 INFO - parseTestManifest@chrome://mochikit/content/manifestLibrary.js:38:5
11:17:38 INFO - getTestManifest/req.onload@chrome://mochikit/content/manifestLibrary.js:49:11
11:17:38 INFO - EventHandlerNonNull
getTestManifest@chrome://mochikit/content/manifestLibrary.js:45:3
11:17:38 INFO - getTestList@chrome://mochikit/content/chrome-harness.js:251:3
11:17:38 INFO - loadTests@chrome://mochikit/content/harness.xul:24:3
11:17:38 INFO - EventListener.handleEvent*@chrome://mochikit/content/harness.xul:48:12
11:17:39 INFO - GECKO(872) | MEMORY STAT | vsize 820MB | vsizeMaxContiguous 675MB | residentFast 256MB | heapAllocated 76MB

Neil, as you are the triage owner of this component, could you please take a look at this?
Thank you!

Flags: needinfo?(enndeakin)
Whiteboard: [stockwell unknown] → [stockwell unknown][stockwell needswork]

Emilio, would you have time to dig deeper on this? See comment 16 for some more details.

Flags: needinfo?(enndeakin) → needinfo?(emilio)

It only seems to be reproducible on win32, which makes it a bit annoying, but I'll try to repro this under rr and see what's going on.

The only way I can see this happening is that some other transitionend event
listener fires before the one we're interested about, so that we go into the
next test and then remove the event listener too soon...

But it's just a guess. In any case this doesn't hurt.

I couldn't repro this under rr... I sent a speculative fix but I'm unconvinced it's the root cause.

Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56dd373240fc
Add the transitionend listener to the right element. r=NeilDeakin
Status: REOPENED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → emilio

Fail reappeared on autoland.
Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=250727891&repo=autoland&lineNumber=17168

Log snippet:

02:15:13 INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/chrome/test_arrowpanel.xul | Test timed out.
02:15:13 INFO - SimpleTest.ok@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:275:18
02:15:13 INFO - reportError@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:121:22
02:15:13 INFO - TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:142:7
02:15:13 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handler
TestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - setTimeout handlerTestRunner._checkForHangs@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:163:5
02:15:13 INFO - TestRunner.runTests/<@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:381:20
02:15:13 INFO - promise callback
TestRunner.runTests@chrome://mochikit/content/tests/SimpleTest/TestRunner.js:368:50
02:15:13 INFO - RunSet.runtests@chrome://mochikit/content/tests/SimpleTest/setup.js:201:14
02:15:13 INFO - RunSet.runall@chrome://mochikit/content/tests/SimpleTest/setup.js:180:12
02:15:13 INFO - hookupTests@chrome://mochikit/content/tests/SimpleTest/setup.js:273:12
02:15:13 INFO - parseTestManifest@chrome://mochikit/content/manifestLibrary.js:38:5
02:15:13 INFO - getTestManifest/req.onload@chrome://mochikit/content/manifestLibrary.js:49:11
02:15:13 INFO - EventHandlerNonNullgetTestManifest@chrome://mochikit/content/manifestLibrary.js:45:3
02:15:13 INFO - hookup@chrome://mochikit/content/tests/SimpleTest/setup.js:253:5
02:15:13 INFO - linkAndHookup@chrome://mochikit/content/harness.xul:45:3
02:15:13 INFO - parseTestManifest@chrome://mochikit/content/manifestLibrary.js:38:5
02:15:13 INFO - getTestManifest/req.onload@chrome://mochikit/content/manifestLibrary.js:49:11
02:15:13 INFO - EventHandlerNonNull
getTestManifest@chrome://mochikit/content/manifestLibrary.js:45:3
02:15:13 INFO - getTestList@chrome://mochikit/content/chrome-harness.js:251:3
02:15:13 INFO - loadTests@chrome://mochikit/content/harness.xul:24:3
02:15:13 INFO - EventListener.handleEvent*@chrome://mochikit/content/harness.xul:48:12
02:15:14 INFO - GECKO(2228) | MEMORY STAT | vsize 818MB | vsizeMaxContiguous 656MB | residentFast 255MB | heapAllocated 76MB
02:15:14 INFO - TEST-OK | toolkit/content/tests/chrome/test_arrowpanel.xul | took 329841ms

Status: RESOLVED → REOPENED
Flags: needinfo?(emilio)
Resolution: FIXED → ---
Target Milestone: mozilla69 → ---

The I have no idea why this is happening and per the comments above I could not repro it. :(

Flags: needinfo?(emilio)
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce7b426e8bbd
Disabled test_arrowpanel.xul on Windows7 x32 debug for mass of failures. r=jmaher
Status: REOPENED → RESOLVED
Closed: 3 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Target Milestone: mozilla69 → ---
Regressions: 1558370
You need to log in before you can comment on or make changes to this bug.