Can't input text from a unicode keyboard to a web form

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: xslf, Assigned: Brade)

Tracking

({intl})

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The only Hebrew keyboard avlible for OSX is a unicode keyboard. However, chimera
refuses to switch to a unicode keyboard or use it- all unicode keyboards are
disabled.

To repro: 
Try to use any unicode keyboard to type in a web form.
(Reporter)

Updated

16 years ago
Keywords: intl
(Reporter)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 120334 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
opps... accidently duped my chimera bug to my mozilla bug. Notice that
thebehavier is not the same: in chimera the problem is more general, where I can
not switch to a unicode keyboard at all, while in mozilla I can only do it when
there is a single tab open
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

16 years ago
Mac OS 10.2 now come with Hebrew support "out of the box"- but Hebrew uses a
unicode keyboard (indenticl to my hakced one), so this is getiing more major.

Comment 4

16 years ago
Oh yes, this also applies to Icelandic, Turkish, Romanian, Greek, Hawaiian, Arabic and 
many others. They keyboard layouts for those in Mac OS X 10.2 are Unicode only.

Comment 5

16 years ago
->brade
Assignee: saari → brade
Status: REOPENED → NEW
(Reporter)

Comment 6

16 years ago
wfm now on build id 2002090705 on osx 10.1.5
However, I see many rtl/input text area issues that have been fixed lately in
mozilla. Should e be getting those fixes, or should I file those bugs here?
(Assignee)

Comment 7

16 years ago
If there are specific bugs that have been fixed, you can cc me and ask for
consideration for chimera branch.  I hesitate to open a bunch of bugs that are
duplicates.

Comment 8

16 years ago
I have quite some problems with unicodes such as umlauts when working with zope
(http://www.zope.org). This is mostly form based entries. This is a total
blocker, I cannot use Chimera for working with zope because it throws unicode
errors. If I enter German Umlauts, Chimera renders some Greek or Cyrillc
symbols. See below:

The latest Chimera browser (userAgent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X;
en-US; rv:1.0.1) Gecko/20021006 Chimera/0.5+) renders this output:

   prof_test1  (ьpдц)
   prof_unicode  (ьабвгдежзийклмнопрстуфхцчшщъыьэюя)


With Mozilla (userAgent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1)
Gecko/20020826) I get the correct encoding:

  prof_test1  (όpδφ)
  prof_unicode  (όΰαβγδεζηθικλμνξοπρςστυφχψωϊϋόύώ�)

Please can you fix this?

Comment 9

16 years ago
Created attachment 102045 [details]
sample screenshots of wrong encoding when working with Chimera and zope
(Reporter)

Comment 10

16 years ago
For comment #8: this sounds like a diffrent problem altogether. If you still
have it, can you please open a separate bug for it?

I would like to mark this bug as FIXED or WFM, since I haven't seen it in more
than a month now.
(Reporter)

Comment 11

16 years ago
since this bug is fixed, resolving so. other issues should be open in a diffrent bug
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.