All users were logged out of Bugzilla on October 13th, 2018

mails corrupted after moved by multiple filters

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: muchan, Assigned: naving)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Multiple Filters are set to move the messages to folders.

After two or more mails are moved to folders (with similar criterias,
that a mail moved to one filter matched with another filter, too),
some moved mails show the content of previouse mail that matched 
and moved to another folder (it shows the headers properly).

(Message source show the corrupted mail, with proper headers but
 wrong body from another mail.)

Occured three times, in a same day.

Chosing the "compact this folder" option of "Inbox" folder restored
the corrupted messages inside the "Inbox" folder, but not in target 
folder where the messages are copied. Probably "move" operation read
wrong boundary of the original mail, temporary written in "Inbox"
folder.



Reproducible: Sometimes
Steps to Reproduce:
1. Set a filter, that moves mail to folder "A" for example, 
   if subject contains "A".
2. Set another filter, that moves mail to folder "AA" for eample,
   if subject -- or in my case, sender -- contains "AA" 
3. Put the second "AA" filter prior to the 1st "A" filter
4. When receiving multiple mails (from POP3 server) matching
   "A", and "AA" filters, headers are shown in proper folders
   according to the filter settings, but messages in "A" folder may
   contain the content of message moved to "AA", or vis versa.

Actual Results:  4. When receiving multiple mails (from POP3 server) matching
   "A", and "AA" filters, headers are shown in proper folders
   according to the filter settings, but messages in "A" folder may
   contain the content of message moved to "AA", or vis versa.

5. Inbox folder still contain of moved data, non-corrupted state,
   but hide these data. "Compact the holder" option will show them
   as unread and undeleted status

Expected Results:  
The content (body) of the moved mail should have its own content,
not from other (previously moved) mail

The "A" filter was actually "subject contains [Contax]" 
on my setting, and these massages are sent from contax.cis.to 
maillist server.

The "AA" filter was actually "sender contains contaxinfo.com"
on my settingm and these massages are sent from contaxinfo.com.

To avoid further problem, I disabled the mail service from
contaxinfo.com, and the bug is not occuring since then.

Comment 1

16 years ago
Mutsumu Nomura: Have you seen this problem in more recent builds?
(Reporter)

Comment 2

16 years ago
No. After I updated (to 1.3b, now 1.4b) I'm using filter without having
problem. (and I already unsubscribed the maillist, whose mails I think 
caused the problem for filtering, so I can't even test it now.)

Comment 3

16 years ago
=>WFM per reporter's comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.