[Dedicated Profiles] The about:profiles page does not display correct information if a profile folder is deleted

VERIFIED FIXED in Firefox 67

Status

()

defect
P2
normal
VERIFIED FIXED
2 months ago
2 months ago

People

(Reporter: cbaica, Assigned: mossop)

Tracking

unspecified
mozilla68
Desktop
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 unaffected, firefox67 verified, firefox68 verified)

Details

Attachments

(2 attachments)

[Affected versions]:

  • Fx67.0b13
  • Fx68.0a1

[Affected platforms]:

  • Windows 10 x64

[Steps to reproduce]:

  1. Launch Firefox and check the about:profiles page. (default-beta profile should be in use).
  2. Close Firefox.
  3. Go to C:\Users\current_user\AppData\Roaming\Mozilla\Firefox\Profiles and delete the 'default-beta' profile folder.
  4. Create a copy of the Firefox install and launch Firefox from that copied folder.
  5. Go to about:profiles.

[Expected result]:

  • The 'default-beta' profile is still displayed
  • The 'Open Folder' buttons are missing for the location from where the profile was deleted (in this case the root path)
  • The profile does not appear to be in use

[Actual result]:

  • The profile appears as if it is in use by another app even though that is not the case

[Regression range]:

  • This is not a regression. The issue occurs since the feature was implemented in Fx 67.0a1.

[Additional notes]:

  • The issue does not occur on Ubuntu or macOS.
  • No other windows app is using the deleted profile folder. There is no other Fx instance running to use the profile
Assignee

Updated

2 months ago
Assignee: nobody → dtownsend
Assignee

Updated

2 months ago
Priority: -- → P2

Comment 2

2 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9bc2f8e17d80
Correctly detect missing directories on Windows. r=Gijs

Comment 3

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Dave, is that something we should uplift to beta?

Flags: needinfo?(dtownsend)
Assignee

Comment 5

2 months ago

Comment on attachment 9060152 [details]
Bug 1546326: Correctly detect missing directories on Windows. r=Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: User may seen an incorrect message on Windows when a profile's folder is missing.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simply adds an additional error check. Very low risk.
  • String changes made/needed: None
Flags: needinfo?(dtownsend)
Attachment #9060152 - Flags: approval-mozilla-beta?
Assignee

Comment 6

2 months ago

(In reply to Pascal Chevrel:pascalc from comment #4)

Dave, is that something we should uplift to beta?

I don't think it is super important, but it is also very very low risk.

The issue is verified fixed on latest Fx68.0a1 buildID: 20190424095359.

Comment on attachment 9060152 [details]
Bug 1546326: Correctly detect missing directories on Windows. r=Gijs

Low risk and minimal patch to polish our user experience with a major new feature in 67, uplift approved for 67 beta 15, thanks.

Attachment #9060152 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

The issue is verified fixed using Fx67.0b15 on Windows 10 x64. The deleted profile no longer appears as 'in use' by any app.

Status: RESOLVED → VERIFIED

Sorry for the spam, but the bot seems to have marked this as a regression even though it is not. Removing tag.

Keywords: regression
OS: Unspecified → Windows
Hardware: Unspecified → Desktop
You need to log in before you can comment on or make changes to this bug.