Closed Bug 1546362 Opened 8 months ago Closed 7 months ago

Resizing or focusing the window will cause flashing white borders

Categories

(Toolkit :: Video/Audio Controls, defect, P2)

All
Windows
defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox68 --- verified

People

(Reporter: tbabos, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Affected versions:
68.0a1 (2019-04-22) (32-bit)

Affected platform:
Windows 10
Windows 8.1

Steps to reproduce:

Expected Result:
The window should be resized and focused without any visual issues

Actual Result:
Resizing or focusing the window will cause flashing white borders

See Also: → 1543027

Hi Timea,

Thanks for reporting - would you mind showing me a screenshot of these white borders? Or a video showing you causing them to appear? I want to see if this is a dupe of bug 1543027, or something else entirely.

Flags: needinfo?(timea.babos)

Here is the screen recording for Windows 10 x64 on latest Nightly: https://streamable.com/6r5kt

On Windows 8 a full white border will also start flickering upon focusing. I will attach a screen recording for that too.

Flags: needinfo?(timea.babos)

And here is the recording on Windows 7 (same as it can be seen on win8). Ignore the spiky video, the screen recorder causes it.
https://streamable.com/s53cw

Thank you!

Priority: -- → P2

I'm not 100% sure why this fixes the issue, but I suspect it's because we used to set chromemargin
on the window after it had had a chance to lay itself out. It seems we can sidestep the issue
by putting the chromemargin on the <html> node directly.

There's the remaining issue where due to rounding, sometimes a very thin (1px) white border will be
displayed around one part of the player window. This has been split out to bug 1549542.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/818f9fcee08e
Avoid strange white border when switching focus to and from the Picture-in-Picture player window. r=dthayer
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → mconley

Build ID 20190626093633
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Verified as fixed on the latest Nightly build on Windows 10.

Status: RESOLVED → VERIFIED

This is still reproducible on latest Nightly71 on amazon prime videos, see recording for reference.
Mike, should we open a new bug or re-open this one?

Flags: needinfo?(mconley)

Let's open a new bug with these STR, thanks Timea. Does it reproduce reliably?

Flags: needinfo?(mconley) → needinfo?(tbabos)

Hey Mike,
Tried a quick test for it but couldn't reproduce it on the first time and I can't really recall if I did anything weird when I encountered this issue.
I'm a bit caught with other feature testing but will submit a new bug for this if I can reproduce it again.

Flags: needinfo?(tbabos)
See Also: → 1598266
You need to log in before you can comment on or make changes to this bug.